Can' t install


I want to install the Acts_as_ferret plugin so I tried “gem install
ferret” and I get the following error:

C:\InstantRails\rails_apps\eatnewcastle>gem install ferret
Attempting local installation of ‘ferret’
Local gem file not found: ferret*.gem
Attempting remote installation of ‘ferret’
Building native extensions. This could take a while…
ERROR: While executing gem … (Errno::ENOENT)
No such file or directory - nmake

Any ideas?

Hi Dave,

first of all: With gem install ferret you are installing ferret, the
engine library of Dave Balmain. acts_as_ferret integrates this lib
into rails applications. You install plugins by utilizing the ruby
script/plugin from withing your rails root. Check the acts_as_ferret
for details.

There are projects trac for ferret as well as for acts_as_ferret.
Doublecheck that you read the installation instructions on both of them.

The base for acts_as_ferret is ferret the library. Unfortunatly you are
trying to build the gem (for ferret the library) on windows. The latest
greatest ferret (0.10.1) isn’t building without some heavy work that
to be not suitable for a beginner. I’m myself didn’t further try to
build it
on windows. Dave Balmain will probably make a win32 gem of ferret in the
next few days that you won’t need to compile for yourself. The error you
reading complains about nmake not on your path which you would need for
building ferret. But you’d better wait for the win32 gem because nmake
won’t help you anyways the bindings code isn’t yet optimized for
building on

So what should you do right now? You might install a gem of ferret below
version 0.10.0. The latest on this branch is 0.9.6 and then you might
install an acts_as_ferret plugin that is working with that branch of
For further details check out the acts_as_ferret trac.

That said even with the 0.9.6 gem you’ll be on the ‘slow’ pure ruby
of ferret while you are on windows. If you’ve got some time your best
might wait for the win32 gem of the ferret 0.10 branch.

Does this make sense to you? Don’t hesitate to ask!



On Tue, Aug 29, 2006 at 07:03:41AM +0200, Raj S. wrote:

Hi Jan,

Thanks for the detailed explanation. I myself tried to install ferret on
windows. After going through a lot of hoops I gave up. I hit the dead
end after a lot of work.

seems to be easier to switch your working env to Linux or OS/X than
getting Ferret to build on Windows :wink:

keeping it in memory.
aaf does store the index in the filesystem. The default path for doing
so is RAILS_ROOT/index//class_name. So if your class is
named Article and you’re in development mode, the index will be stored
in RAILS_ROOT/index/development/article/.

If you like, you can specify another index directory with the index_dir

class Article
acts_as_ferret :index_dir => “#{RAILS_ROOT}/shared/index/article”


webit! Gesellschaft für neue Medien mbH
Dipl.-Wirtschaftsingenieur Jens Krämer [email protected]
Schnorrstraße 76 Tel +49 351 46766 0
D-01069 Dresden Fax +49 351 46766 66

Hi Jan,

Thanks for the detailed explanation. I myself tried to install ferret on
windows. After going through a lot of hoops I gave up. I hit the dead
end after a lot of work.

Anyway I spoke to my hosting provider about using ferret installed on
their server and they allowed me to work with it. That was nice given
that I would be doing sort of development work there.

I used aaf and everything works like a charm.

Since the only thing I did was to add a line stating ‘acts_as_ferret’, I
believe the indexing is being done on the memory. In order to get the
indexing on the hard drive I need to do something like

index = => ‘/path/to/index’)

When I’m using aaf where do I specify this path. How do I tell aaf to
keep all the indexed information at a particular path rather than
keeping it in memory.