Can activesupport gem be used in "standalone" fashion?


#1

i’m using ruby 1.8.2, rubygem 0.8.10, rails 1.0.0 where activesupport
version = 1.2.5

when i try to run this in RADRail, i get a NoMethodError:

require ‘rubygems’
require_gem “activesupport”

print Time.now + 2.days

the error message is: c:/e312workspace/first/test3.rb:5: undefined
method `days’ for 2:Fixnum (NoMethodError)

is there a way to use the numeric/time core_ext in a plain ruby app? if
so, how?
thanks for any help!


#2

I’m not sure why the above doesn’t work, but check below for a working
version.

powerbook:~ michaelguterl$ irb
irb(main):001:0> require ‘rubygems’
=> true
irb(main):002:0> require ‘active_support’
=> true
irb(main):003:0> Time.now + 2.days
=> Sun Apr 02 16:16:22 EDT 2006
irb(main):004:0>


#3

Thanks! That worked. Not sure what was wrong with require_gem

Michael G. removed_email_address@domain.invalid wrote: I’m not sure why the above
doesn’t work, but check below for a working
version.

powerbook:~ michaelguterl$ irb
irb(main):001:0> require ‘rubygems’
=> true
irb(main):002:0> require ‘active_support’
=> true
irb(main):003:0> Time.now + 2.days
=> Sun Apr 02 16:16:22 EDT 2006
irb(main):004:0>


#4

thanks!

Logan C. removed_email_address@domain.invalid wrote:
On Mar 31, 2006, at 3:23 PM, john peter wrote:

Thanks! That worked. Not sure what was wrong with require_gem

Nothing is wrong with require_gem. It has an unfortunate name though.
It should really be called activate_gem or something similar.
require_gem only actually require’s the library if it uses
autorequire, which is deprecated now.
require_gem is to select things like a given version of a gem, ie:
require_gem ‘some_gem’, ‘>= 1.0’
you still have to do the
require ‘some_gem’ line


#5

On Mar 31, 2006, at 3:23 PM, john peter wrote:

Thanks! That worked. Not sure what was wrong with require_gem

Nothing is wrong with require_gem. It has an unfortunate name though.
It should really be called activate_gem or something similar.
require_gem only actually require’s the library if it uses
autorequire, which is deprecated now.
require_gem is to select things like a given version of a gem, ie:
require_gem ‘some_gem’, ‘>= 1.0’
you still have to do the
require ‘some_gem’ line