Calling plotutils from xemacs using Ruby GSL


#1

I’m using ruby from Xemacs on OSX. Ruby works well in IRB mode from
Xemacs,
but I can’t call plotutils successfully from Xemacs, even though I know
it
is installed. I’m trying to use rubygsl, which also runs fine, except
it
can’t run plotutils per the example here:

http://rb-gsl.rubyforge.org/screenshot.html#4

The error I get is:

#!/usr/bin/env ruby
require(“gsl”);
poly=Poly[1.5,-1.25,-3.75,0,1];
roots=poly.solve
[ [5.000e-01 0.000e+00] [-1.000e+00 0.000e+00] [-1.500e+00 0.000e+00] [
2.000e+00 0.000e+00] ]
#GSL::Vector::Complex:0x701330
x=Vector.linspace(-2.5, 2.5, 20);y=poly.eval(x);
zero=Vector.calloc(4);
graph([x,y], [roots.real,zero], “-T X -C -g 3 -S 4”)
NoMethodError: GNU plotutils required
from (irb):7:in `graph’
from (irb):7

With no windows opening.

Thanks