Cache_classes = true but they are not being cached

I am running my app in production mode on an apache2 web server but the
code is not be cached. That is, changes to code are being picked up
without having to restart the web server.

I would prefer this not to happen from a performance point of view.

I am running rails 1.1.6 and ruby 1.8.2

I know I am running in production mode as I can see the requests coming
up in the production.log file as I run the app.

My production.rb file is:

Settings specified here will take precedence over those in

config/environment.rb

The production environment is meant for finished, “live” apps.

Code is not reloaded between requests

config.cache_classes = true

Use a different logger for distributed setups

config.logger = SyslogLogger.new

Full error reports are disabled and caching is turned on

config.action_controller.consider_all_requests_local = false
config.action_controller.perform_caching = true

Enable serving of images, stylesheets, and javascripts from an asset

server

config.action_controller.asset_host =

http://assets.example.com

send real emails

config.action_mailer.delivery_method = :smtp
#config.action_mailer.delivery_method = :test

Disable delivery errors if you bad email addresses should just be

ignored

config.action_mailer.raise_delivery_errors = false

Any ideas?

Cheers

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs