Button_to_remote syntax


#1

Hey

I’m trying to make a button_to_remote that also has an associated style.

It works fine as a button_to:
<%= button_to “Paid”, has_paid_event_booking_path(booking,
booking.event), :method => :post, :style =>
“background:url(/images/money_add.png) left no-repeat; padding-left:
15px” %>

but then when I change it to button_to_remote:
<%= button_to_remote “Paid”, has_paid_event_booking_path(booking,
booking.event), :method => :post, :before => “Effect.Fade('not_paid_” +
booking.id.to_s + “’)”,:style => “background:url(/images/money_add.png)
left no-repeat; padding-left: 15px” %>

with the above code, the :before is ignored

So, I change the path to a :url hash:
<%= button_to_remote “Paid”, :url =>
has_paid_event_booking_path(booking, booking.event), :method => :post,
:before => “Effect.Fade('not_paid_” + booking.id.to_s + “’)”,:style =>
“background:url(/images/money_add.png) left no-repeat; padding-left:
15px” %>

and then the :before works, but now the style is ignored!

How do I fix this?

Thanks in advance
Steve Brown


#2

On May 26, 4:40 pm, Stephen B. removed_email_address@domain.invalid
wrote:
above code, the :before is ignored

So, I change the path to a :url hash:
<%= button_to_remote “Paid”, :url =>
has_paid_event_booking_path(booking, booking.event), :method => :post,
:before => “Effect.Fade('not_paid_” + booking.id.to_s + “’)”,:style =>
“background:url(/images/money_add.png) left no-repeat; padding-left:
15px” %>

and then the :before works, but now the style is ignored!

html options need to be in a second hash of options, ie
button_to_remote ‘Foo’, {…}, {…}

Fred


#3

Frederick C. wrote:

html options need to be in a second hash of options, ie
button_to_remote ‘Foo’, {…}, {…}

Fred

Thanks. Works like a charm.