/bundler/runtime.rb:77:in `require': cannot load such file -- global (LoadError)

hi, need help with a rails 4 app:

$ bundle exec rails s -b 0.0.0.0 -p 3001
/home/administrator/.rvm/gems/[email protected]/gems/bundler-1.11.2/lib/bundler/shared_helpers.rb:78:
warning: Insecure world writable dir /home/administrator/.rvm/gems in
PATH,
mode 042777
/home/administrator/.rvm/gems/[email protected]/gems/bundler-1.11.2/lib/bundler/shared_helpers.rb:78:
warning: Insecure world writable dir /home/administrator/.rvm/gems in
PATH,
mode 042777
/home/administrator/.rvm/gems/[email protected]/gems/bundler-1.11.2/lib/bundler/shared_helpers.rb:78:
warning: Insecure world writable dir /home/administrator/.rvm/gems in
PATH,
mode 042777
/home/administrator/.rvm/gems/[email protected]/gems/bundler-1.11.2/lib/bundler/runtime.rb:77:in
require': cannot load such file -- global (LoadError) from /home/administrator/.rvm/gems/[email protected]/gems/bundler-1.11.2/lib/bundler/runtime.rb:77:inblock (2 levels) in require’
from
/home/administrator/.rvm/gems/[email protected]/gems/bundler-1.11.2/lib/bundler/runtime.rb:72:in
each' from /home/administrator/.rvm/gems/[email protected]/gems/bundler-1.11.2/lib/bundler/runtime.rb:72:inblock in require’
from
/home/administrator/.rvm/gems/[email protected]/gems/bundler-1.11.2/lib/bundler/runtime.rb:61:in
each' from /home/administrator/.rvm/gems/[email protected]/gems/bundler-1.11.2/lib/bundler/runtime.rb:61:inrequire’
from
/home/administrator/.rvm/gems/[email protected]/gems/bundler-1.11.2/lib/bundler.rb:99:in
require' from /home/administrator/rorapps/myapp/config/application.rb:12:in<top (required)>’
from
/home/administrator/.rvm/gems/[email protected]_gemset/gems/railties-4.0.0/lib/rails/commands.rb:76:in
require' from /home/administrator/.rvm/gems/[email protected]_gemset/gems/railties-4.0.0/lib/rails/commands.rb:76:inblock in <top (required)>’
from
/home/administrator/.rvm/gems/[email protected]_gemset/gems/railties-4.0.0/lib/rails/commands.rb:73:in
tap' from /home/administrator/.rvm/gems/[email protected]_gemset/gems/railties-4.0.0/lib/rails/commands.rb:73:in<top (required)>’
from script/rails:6:in require' from script/rails:6:in

not sure what to look for now - line12 is this:
Bundler.require(*Rails.groups)

thx

i have installed bundler global and in the rvm gemset

n 18 December 2015 at 19:58, tom [email protected] wrote:

warning: Insecure world writable dir /home/administrator/.rvm/gems in PATH,
mode 042777

/home/administrator/.rvm/gems/[email protected]/gems/bundler-1.11.2/lib/bundler/runtime.rb:77:in

`require’: cannot load such file – global (LoadError)

Can you post your application.rb here please.

Colin

hi collin,

this is a ror3 app which i have convertred to a ror4 app - but it was
all
good and i even deployed it couple of times. not sure what changed in
the
last 10 days, in fact i havent changed anything…
for sanity check i took a application.rb file from a new app and
replaced
mine with it after renaming the module - but same error.
how can i trace that down?

----------require File.expand_path(’…/boot’, FILE)

require ‘rails/all’

Require the gems listed in Gemfile, including any gems

you’ve limited to :test, :development, or :production.

Bundler.require(*Rails.groups)

module SomeNameHere
class Application < Rails::Application
# Settings in config/environments/* take precedence over those
specified here.
# Application configuration should go into files in
config/initializers
# – all .rb files in that directory are automatically loaded.

# Set Time.zone default to the specified zone and make Active Record

auto-convert to this zone.
# Run “rake -D time” for a list of tasks for finding time zone
names.
Default is UTC.
# config.time_zone = ‘Central Time (US & Canada)’

# The default locale is :en and all translations from

config/locales/.rb,yml are auto loaded.
# config.i18n.load_path += Dir[Rails.root.join(‘my’, ‘locales’,
'
.{rb,yml}’).to_s]
# config.i18n.default_locale = :de

# Do not swallow errors in after_commit/after_rollback callbacks.
config.active_record.raise_in_transactional_callbacks = true

end
end

bundle install was working fine.

i rolled back so its working again, not sure what happened - so thx
again

On 21 December 2015 at 14:28, tom [email protected] wrote:

bundle install was working fine.

i rolled back so its working again, not sure what happened - so thx again

Presumably you will find out when you roll forwards again a bit at a
time. Post here when you find out so that anyone googling the error
and finding this thread will know the answer.

Colin

On 19 December 2015 at 21:37, tom [email protected] wrote:

hi collin,

this is a ror3 app which i have convertred to a ror4 app - but it was all
good and i even deployed it couple of times. not sure what changed in the
last 10 days, in fact i havent changed anything…

Go back to the last working version from you source control system.
Something must have changed, either the app or the environment.

Do you get any errors when you run
bundle install

If not then post your Gemfile.lock

Colin

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs