Bundler gem: "no such file to load"

Hi guys,

I have some troubles with a Ruby gem… named Bundler. My OS is Ubuntu
10.04.

My environment is as follows:

$ gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.6
  - RUBY VERSION: 1.9.1 (2010-01-10 patchlevel 378) [i486-linux]
  - INSTALLATION DIRECTORY: /usr/lib/ruby1.9.1/gems/1.9.1
  - RUBY EXECUTABLE: /usr/bin/ruby1.9.1
  - EXECUTABLE DIRECTORY: /usr/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-linux
  - GEM PATHS:
     - /usr/lib/ruby1.9.1/gems/1.9.1
     - /home/mo/.gem/ruby/1.9.1
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://rubygems.org/

$ cat /proc/version

Linux version 2.6.32-21-generic ([email protected]) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010

$ ruby -v

ruby 1.9.1p378 (2010-01-10 revision 26273) [i486-linux]

$ gem -v

1.3.6

My local gems are:

  • abstract (1.0.0)
  • actionmailer (3.0.0.beta3)
  • actionpack (3.0.0.beta3)
  • activemodel (3.0.0.beta3)
  • activerecord (3.0.0.beta3)
  • activeresource (3.0.0.beta3)
  • activesupport (3.0.0.beta3)
  • arel (0.3.3)
  • builder (2.1.2)
  • bundler (0.9.24)
  • erubis (2.6.5)
  • i18n (0.3.7)
  • mail (2.2.0)
  • memcache-client (1.8.3)
  • mime-types (1.16)
  • polyglot (0.3.1)
  • rack (1.1.0)
  • rack-mount (0.6.3)
  • rack-test (0.5.3)
  • rails (3.0.0.beta3)
  • railties (3.0.0.beta3)
  • rake (0.8.7)
  • text-format (1.0.0)
  • text-hyphen (1.0.0)
  • thor (0.13.6)
  • treetop (1.4.5)
  • tzinfo (0.3.20)

And here is my error:

$ irb1.9.1 -rubygems
irb(main):001:0> require "bundler"
LoadError: no such file to load -- bundler
 from (irb):1:in `require'
 from (irb):1
 from /usr/bin/irb1.9.1:12:in `<main>'

I got the same error when I try to start Rails 3:

$ rails start
/home/mo/quick_test_2/config/boot.rb:4:in `require': no such file to

load – bundler (LoadError)
from /home/mo/quick_test_2/config/boot.rb:4:in <top (required)>' from script/rails:8:inrequire’
from script/rails:8:in `’

More information about my version of Bundler:

$ gem list -d bundler

*** LOCAL GEMS ***

bundler (0.9.24)
    Authors: Carl L., Yehuda K., André Arko
    Rubyforge: http://rubyforge.org/projects/bundler
    Homepage: http://github.com/carlhuda/bundler
    Installed at: /usr/lib/ruby1.9.1/gems/1.9.1

    The best way to manage your application's dependencies

Thanks for any help.

Regards

Hi there.

Moad M. wrote:

$ ruby -v
$ irb1.9.1 -rubygems

The first thing I notice is that you run ruby, with no version number,
but you run irb1.9.1. I don’t have much experience with ruby on
Ubuntu, but that seems a little weird to me.

The next thing is that you are using ruby 1.9.1. That version of ruby
has several regressions from 1.8.7 that affect bundler. They are fixed
in 1.9.2 (which is not released yet). If possible, can you try to
reproduce the problem with ruby 1.8.7 or ruby 1.9.2, from the latest
source control version?

If that doesn’t work for you, I strongly suggest visiting the Bundler
issue tracker at http://github.com/carlhuda/bundler/issues and opening a
ticket.

Thanks,
Andre Arko

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs