Bunch of assert_tag tests failing in 3.99.3

Hey Scott and others,

First of all, excellent work! I just installed 3.99.3 and it looks
great.
I’m so happy to have a sweet rails app to run the blog for my new rails
based site called Wamily.

Everything seems to be working fine, except I’m getting 6 failures out
of
rake. They’re all coming from ‘assert_tag’ tests. I’ve included the
output
from rake at the end of this email.

This could be because I installed Typo a little bit non-traditionally. I
used the installer on my windows machine and it worked fine, then I
packed
up the whole directory and stuck it on my Dreamhost server, configured
FCGI
with Apache, and it’s working fine in development mode (haven’t tried
production mode yet). Could the move from Windows to Linux mess this up?
Notice in the output from rake below the mysterious looking “\n” end of
line
characters in the HTML output there. Sounds to me like some character
set
incompatibility … Is that what’s making these tests fail?

Thanks for any suggestions,
Nate

And here’s the test output that failed …

Started
…FFF…F…F…
…F…
Finished in 125.327245 seconds.

  1. Failure:
    test_full_post(Admin::ArticlePreviewTest)
    [./test/functional/admin/article_preview_test.rb:61]:
    expected tag, but no tag found matching
    {:after=>{:after=>{:content=>nil,
    :tag=>“h4”}, :child=>“A body”, :tag=>“p”}, :child=>“An extension”,
    :tag=>“p”} in:

    A title

    \n\n

    A body

    An extension

    \n”.
    is not true.
  2. Failure:
    test_only_body(Admin::ArticlePreviewTest)
    [./test/functional/admin/article_preview_test.rb:37]:
    expected tag, but no tag found matching {:after=>{:content=>nil,
    :tag=>“h4”}, :child=>“A body”, :tag=>“p”} in:

    \n\n

    A body

    \n”.
    is not true.
  3. Failure:
    test_only_extended(Admin::ArticlePreviewTest)
    [./test/functional/admin/article_preview_test.rb:47]:
    expected tag, but no tag found matching {:after=>{:content=>nil,
    :tag=>“h4”}, :child=>“An extension”, :tag=>“p”} in:

    \n\n

    An extension

    \n”.
    is not true.
  4. Failure:
    test_category_container(Admin::CategoriesControllerTest)
    [./test/functional/admin/categories_controller_test.rb:96]:
    expected tag, but no tag found matching {:children=>{:count=>7,
    :only=>{:children=>{:count=>3, :only=>{:tag=>/t[dh]/}}, :tag=>“tr”}},
    :tag=>“table”} in:
    "

    \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n \n
    Category titleArticlesDelete
    Software1 article
    Hardware1 article
    \"Checked\"
src=\"/images/checked.gif?1153270877\" Personal4 articles
    Life On Marsno articles
    \"Checked\"
src=\"/images/checked.gif?1153270877\" The Permalink doesn't match1 article
    this & that1 article
    ". is not true.
    1. Failure:
      test_reorder(Admin::CategoriesControllerTest)
      [./test/functional/admin/categories_controller_test.rb:107]:
      expected tag, but no tag found matching {:children=>{:count=>6,
      :only=>{:attributes=>{:id=>/category_\d+/}, :tag=>“li”}},
      :attributes=>{:id=>“category_list”}, :tag=>“ul”} in:
      "<ul id=“category_list”>\n <li id=“category_1”>Software
    2. \n
Hardware\n
  • Personal
  • \n
  • Life On Mars
  • \n
  • The Permalink doesn't match
  • \n
  • this & that
  • \n \n\n(Done)\n\n\n//\n". is not true.
    1. Failure:
      test_read_article_with_comments_and_trackbacks(ArticlesControllerTest)
      [./test/functional/articles_controller_test.rb:369]:
      expected tag, but no tag found matching {:children=>{:count=>2,
      :only=>{:tag=>“li”}}, :attributes=>{:id=>“trackbackList”}, :tag=>“ol”}
      in:
      "<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\" \" ... is not true.

    205 tests, 795 assertions, 6 failures, 0 errors
    rake aborted!
    Test failures

    (See full trace by running task with --trace)

    This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

    | Privacy Policy | Terms of Service | Remote Ruby Jobs