Building portaudio and comedi

I have been able to build all modules checked out from cvs except
gr-audio-portaudio and gr-comedi. For portaudio I am getting this error
message:

checking for portaudio-2.0 >= 19… Package portaudio-2.0 was not found
in
the pkg-config search path. Perhaps you should add the directory
containing
`portaudio-2.0.pc’ to the PKG_CONFIG_PATH environment variable No
package
‘portaudio-2.0’ found
configure: error: Library requirements (portaudio-2.0 >= 19) not met;
consider adjusting the PKG_CONFIG_PATH environment variable if your
libraries are in a nonstandard prefix so pkg-config can find them.

What I don’t get is that I have installed the latest version of
portaudio
that I could find as well as portaudio-devel, so from what I know this
should be working. Yet, when I go to locate portaudio-2.0.pc I cannot
find
it on my computer either. Anyone know what may be going on here?

Newell

On Mon, Jun 19, 2006 at 08:43:23AM +0000, Newell J. wrote:

libraries are in a nonstandard prefix so pkg-config can find them.

What I don’t get is that I have installed the latest version of portaudio
that I could find as well as portaudio-devel, so from what I know this
should be working. Yet, when I go to locate portaudio-2.0.pc I cannot find
it on my computer either. Anyone know what may be going on here?

Newell

As it mentions in gr-audio-portaudio/README this code requires the
v19-devel branch.

Summary: no need to build gr-audio-portaudio or gr-comedi

Eric

OSS and Alsa have real trouble with some of the higher end professional
cards such a the M-Audio Delta series in dealing with the number of
channels these high end cards can offer. Portaudio handles the plughw
case internally. It is rapidly maturing and will provide a cross
platform audio interface. It is not finished but why should that be a
bother for us in a system that is never finished (and hopefully will not
be soon)? I use the portaudio interface exclusively. If you are on
Linux and you are using a standard 2 channel stereo sound card, such as
the one on your motherboard, I probably agree. Don’t bother.

Bob

Eric B. wrote:

configure: error: Library requirements (portaudio-2.0 >= 19) not met;

[email protected]
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio


AMSAT VP Engineering. Member: ARRL, AMSAT-DL, TAPR, Packrats,
NJQRP/AMQRP, QRP ARCI, QCWA, FRC. ARRL SDR Wrk Grp Chairman
Laziness is the number one inspiration for ingenuity. Guilty as
charged!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs