Building mblock fails when building in a separate tree


#1

Hi,

I create a separate folder when building gnuradio (mkdir -p build &&
pushd build && …/configure ). This however fails when it comes to
mblock:

[trondd@dhcp-3254 mblock]$ pwd
/home/trondd/src/gnuradio/trunk/build/mblock
[trondd@dhcp-3254 mblock]$ make
Making all in src
make[1]: Entering directory
/home/trondd/src/gnuradio/trunk/build/mblock/src' Making all in lib make[2]: Entering directory/home/trondd/src/gnuradio/trunk/build/mblock/src/lib’
GUILE_LOAD_PATH="/home/trondd/src/gnuradio/trunk/build/mblock/src/lib/…/…/…/…/pmt/src/scheme:/home/trondd/src/gnuradio/trunk/build/mblock/src/lib/…/…/…/…/mblock/src/scheme"
/usr/bin/guile -e main -s
…/…/…/…/mblock/src/scheme/gnuradio/compile-mbh.scm qa_bitset.mbh
qa_bitset_mbh.cc
ERROR: In procedure open-file:
ERROR: No such file or directory: “qa_bitset.mbh”
make[2]: *** [qa_bitset_mbh.cc] Error 1
make[2]: Leaving directory
/home/trondd/src/gnuradio/trunk/build/mblock/src/lib' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory/home/trondd/src/gnuradio/trunk/build/mblock/src’
make: *** [all-recursive] Error 1


Trond D.


#2

On Thu, May 03, 2007 at 04:35:21PM +0200, Trond D. wrote:

Hi,

I create a separate folder when building gnuradio (mkdir -p build &&
pushd build && …/configure ). This however fails when it comes to
mblock:

Thanks. Fix in progress :wink:

Eric


#3

On Thu, May 03, 2007 at 08:45:13AM -0700, Eric B. wrote:

On Thu, May 03, 2007 at 04:35:21PM +0200, Trond D. wrote:

Hi,

I create a separate folder when building gnuradio (mkdir -p build &&
pushd build && …/configure ). This however fails when it comes to
mblock:

Fixed in trunk r5233.

Eric