Building CUDA with GNUradio issues


I am having alot of problems building CUDA with the current CUDA-enable
GUNRadio branch. I am using Fedora 10.

I followed the
and everything is fine up until trying to ‘make’ gpgpu-wip

I understand that we may need to use GCC 3.4 which I do by doing this
CC=gcc34 CXX=g++34 ./configure --with-cuda=/usr/local/cuda

but this error continues to show up:

g++34 -g -O2 -Wall -Woverloaded-virtual -pthread -o .libs/test_runtime
-L/usr/local/cuda/lib -L/root/NVIDIA_CUDA_SDK/lib
-L/root/NVIDIA_CUDA_SDK/common/lib/linux -lcppunit -ldl
-lcudart -lcutilD
-lrt -lfftw3f -Wl,–rpath -Wl,/usr/local/lib
/usr/lib/gcc/i386-redhat-linux/3.4.6/…/…/…/ undefined
reference to `std::basic_ostream<char, std::char_traits >&
std::basic_ostream<char, std::char_traits

/usr/lib/gcc/i386-redhat-linux/3.4.6/…/…/…/ undefined
reference to std::basic_ostream<char, std::char_traits<char> >& std::__ostream_insert<char, std::char_traits<char> (std::basic_ostream<char, std::char_traits<char> >&, char const*, int)@GLIBCXX_3.4.9' collect2: ld returned 1 exit status make[4]: *** [test_runtime] Error 1 make[4]: Leaving directory /home/admin/gpgpu-wip/gnuradio-core/src/tests’
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory /home/admin/gpgpu-wip/gnuradio-core/src' make[2]: *** [all-recursive] Error 1 make[2]: Leaving directory /home/admin/gpgpu-wip/gnuradio-core’
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/admin/gpgpu-wip’
make: *** [all] Error 2

Is this related to not using the right gcc version? But I thought I took
care of that issue. The wiki does say that gcc/g++4.1 was the one that
successful. But I cant seem to get gcc 4.1 working on my F10, just alot
issues with missing std header files to missing cpp and etc. I tried
installing gcc4.1 from rpm as well as trying to build it from source,
both methods did not work.

Is gcc4.1 the only way to a successful CUDA-Enable GNUradio build??
is not possible? I guess this is more of a linux question but how did
guys install gcc/g++4.1 on top of the later versions of gcc? There is no
such rpm as compat-gcc-41 as there is for gcc3.4 so gcc 4.1 is rather a

Please help!

I solved the issue

It wasnt a compatibility issue. I was able to build with gcc/g++ 4.3
came with F10.

The problem is the file: is missing a #include

Recommend adding that to the SVN repository.

2009/6/24 Yu-Hua Y. [email protected]