Build problems on OS X PPC


#1

I have been having problems building recent Ruby 1.9 releases on my
old PowerBook. I was wondering if anyone else on OX X 10.5.5 PPC has
been having issues, or whether it might be some failure of my hardware.

Is RubyForge the right place to report these issues:

http://rubyforge.org/tracker/?func=detail&aid=22293&group_id=426&atid=1698
[[#22293] ruby-trunk make test failures OS X 10.5.5 PPC since after
revision 18754]
http://rubyforge.org/tracker/?func=detail&aid=22294&group_id=426&atid=1698
[[#22294] Ruby 1.9.0-5 fails to build on OS X 10.5.5 PPC]

If not, then where should I report them?

Mike

Mike S. removed_email_address@domain.invalid
http://www.stok.ca/~mike/

The “`Stok’ disclaimers” apply.


#2

On Oct 8, 2008, at 03:48 , Mike S. wrote:

http://rubyforge.org/tracker/?func=detail&aid=22294&group_id=426&atid=1698
[[#22294] Ruby 1.9.0-5 fails to build on OS X 10.5.5 PPC]

If not, then where should I report them?

ruby-core would get the quickest response.


#3

As suggested I am forwarding my message to ruby-talk.

Regards,

MIchael

Begin forwarded message:

old PowerBook. I was wondering if anyone else on OX X 10.5.5 PPC

If not, then where should I report them?

ruby-core would get the quickest response.

Mike S. removed_email_address@domain.invalid
http://www.stok.ca/~mike/

The “`Stok’ disclaimers” apply.


#4

Hi,

At Thu, 9 Oct 2008 07:26:25 +0900,
Mike S. wrote in [ruby-core:19231]:

http://rubyforge.org/tracker/?func=detail&aid=22293&group_id=426&atid=1698
[[#22293] ruby-trunk make test failures OS X 10.5.5 PPC since
after revision 18754]

I think r19700 fixed it.

http://rubyforge.org/tracker/?func=detail&aid=22294&group_id=426&atid=1698
[[#22294] Ruby 1.9.0-5 fails to build on OS X 10.5.5 PPC]

Does this reproduce with the latest?


#5

On Oct 9, 2008, at 12:10 AM, Nobuyoshi N. wrote:

Hi,

At Thu, 9 Oct 2008 07:26:25 +0900,
Mike S. wrote in [ruby-core:19231]:

http://rubyforge.org/tracker/?func=detail&aid=22293&group_id=426&atid=1698
[[#22293] ruby-trunk make test failures OS X 10.5.5 PPC since
after revision 18754]

I think r19700 fixed it.

I have just successfully compiled & tested r19725. Thanks.

http://rubyforge.org/tracker/?func=detail&aid=22294&group_id=426&atid=1698
[[#22294] Ruby 1.9.0-5 fails to build on OS X 10.5.5 PPC]

Does this reproduce with the latest?

I will wait until 1.9.0-6 appears to try. I downloaded 1.9.0-5 again
and tried the build and it still fails at:

rbconfig.rb updated
./miniruby -I./lib -I.ext/common -I./- -r./ext/purelib.rb ./enc/
make_encmake.rb --builtin-encs=“ascii.o us_ascii.o unicode.o utf_8.o”
–builtin-transes=“newline.o” enc.mk
/usr/local/mike/src/ruby-1.9.0-5/lib/shellwords.rb:35:in shellsplit': undefined methodscan’ for nil:NilClass (NoMethodError)
from /usr/local/mike/src/ruby-1.9.0-5/lib/mkmf.rb:25:in <top (required)>' from ./enc/make_encmake.rb:8:inload’
from ./enc/make_encmake.rb:8:in `’
make: *** [enc.mk] Error 1

Mike

Mike S. removed_email_address@domain.invalid
http://www.stok.ca/~mike/

The “`Stok’ disclaimers” apply.