Build Problem

I’m trying to build from the trunk. I’m able to configure and make
without any problems, but when I try to make install I get an error on
this line:
/usr/bin/install -c -m 644 …/…/README.hacking -3.1svn
with the error stating that -3 is not a valid argument. It turns out
that -3.1svn is a folder in the gnuradio/gnuradio-core/doc folder. I
just deleted the -3.1svn folder hoping it was an artifact of some
sort(hey, I can dream) and I ran configure + make again. The folder
was not there this time so I figured all was well. When I ran make
install the -3.1svn folder was apparently created again, causing make
install to fail again for the same reason. Hoping that this was just
an isolated instance in the /gnuradio-core/doc folder I edited the in the /gnuradio-core/ to ignore the /doc folder. I then
ran configure, make and make install. Once again make install failed,
but this time at a different spot. Another -3.1svn* folder was created
in gr-trellis/doc. With the help of bpadalino on IRC we found this
line in the makefiles:
gr_docdir = $(docdir)-$(VERSION)
It looks like for whatever reason $docdir is not getting defined or is
getting defined as whitespace. With the gnuradio version being 3.1 I
ended up with all of my doc folders having some form of a -3.1svn
folder in them. What is causing $docdir to not be defined properly?


With the help of Josh B. I was able to build the trunk. I was using
autoconf 2.59 which does not have the docdir. Installing newer
versions of the autotools fixed the problem.