Build-gnuradio on Scientific Linux 6.3

I am having a problem with the build-gnuradio script on Scientific Linux
6.3 (x86_64). I added myself to sudoers and tried running the script but
I
usually get this this output:

Starting all functions at: Wed Mar 20 12:31:31 EDT 2013
SUDO privileges are required
Do you have SUDO privileges?y
Continuing with script
./build-gnuradio.sh: line 1249: tmp18685: Permission denied
cat: tmp18685: No such file or directory
Installing prequisites…Checking for library libusb …Found library
libusb
Checking for library libboost …Found library libboost
Checking for library libcppunit …Found library libcppunit
Checking for library libguile …Found library libguile
Checking for library libfftw …Found library libfftw
Checking for library libgsl …Found library libgsl
Done
touch: cannot touch `touch18685’: Permission denied
Fetching Gnu Radio via GIT…Could not find gnuradio/gnuradio-core after
GIT checkout
GIT checkout of Gnu Radio failed!

I looked at the shell script’s line 1249 and I can see that it wants to
access my sudoers file. Am I suppose to change sudoers’ default
permissions? This problem has been frustrating me for a while especially
considering I have successfully installed GNU Radio on RHEL before. I
appreciate any help on this matter.

Thanks.

Jonathan F.

On 20 Mar 2013 12:47, Jonathan F. wrote:

I am having a problem
with the build-gnuradio script on Scientific Linux 6.3 (x86_64). I added
myself to sudoers and tried running the script but I usually get this
this output:

Starting all functions at: Wed Mar 20 12:31:31 EDT
2013
SUDO privileges are required
Do you have SUDO privileges?y

Continuing with script

./build-gnuradio.sh: line 1249: tmp18685:
Permission denied
cat: tmp18685: No such file or directory

Installing prequisites…Checking for library libusb …Found library
libusb

Checking for library libboost …Found library libboost

Checking for library libcppunit …Found library libcppunit

Checking
for library libguile …Found library libguile
Checking for library
libfftw …Found library libfftw
Checking for library libgsl …Found
library libgsl
Done
touch: cannot touch `touch18685’: Permission
denied
Fetching Gnu Radio via GIT…Could not find
gnuradio/gnuradio-core after GIT checkout
GIT checkout of Gnu Radio
failed!

I looked at the shell script’s line 1249 and I can see that
it wants to access my sudoers file. Am I suppose to change sudoers’
default permissions? This problem has been frustrating me for a while
especially considering I have successfully installed GNU Radio on RHEL
before. I appreciate any help on this matter.

Thanks.

Jonathan
Fox

It’s never been tested on Scientific Linux, and the RHEL support is
only very lightly tested–by exactly one person, as far as I know.

Are
you running this in a directory that you wouldn’t have write-access to
if root? Like an NFS mount maybe?

On Wed, Mar 20, 2013 at 1:51 PM, [email protected] wrote:

Do you have SUDO privileges?y
Done


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

I tried running it in /usr/local and /usr/local/src. Right now I am
trying
in /home/$USER/workspace and I think that could of done the trick. I
suppose when it is done or if it finishes, I can move the source
directories to /usr/local/src.

This problem seems odd because I can run this script in /usr/local on
Ubuntu boxes but not in a RHEL clone.

Thanks for the response.

Jon

Possibly Ubuntu sets up /usr/local to be regular-user
writeable, but that would be a horrible security flaw.

At least for my Ubuntu 12.04 /usr/local is owned by root:root with 0755
permissions and everything else would have given me nightmares :wink:

Maybe you started the script with sudo, instead of letting the script
itself call sudo, then you would have had the necessary permissions.

Yours
Martin

On 20 Mar 2013 14:03, Jonathan F. wrote:

On Wed, Mar 20, 2013
at 1:51 PM, <[email protected] [3]> wrote:

On 20 Mar 2013 12:47,
Jonathan F. wrote:

I am having a problem with the
build-gnuradio script on Scientific Linux 6.3 (x86_64). I added myself
to sudoers and tried running the script but I usually get this this
output:

Starting all functions at: Wed Mar 20 12:31:31 EDT
2013

SUDO privileges are required
Do you have SUDO
privileges?y

Continuing with script
./build-gnuradio.sh: line
1249: tmp18685: Permission denied

cat: tmp18685: No such file or
directory

Installing prequisites…Checking for library libusb
…Found library libusb

Checking for library libboost …Found
library libboost

Checking for library libcppunit …Found library
libcppunit

Checking for library libguile …Found library
libguile

Checking for library libfftw …Found library libfftw

Checking for library libgsl …Found library libgsl

Done
touch:
cannot touch `touch18685’: Permission denied

Fetching Gnu Radio via
GIT…Could not find gnuradio/gnuradio-core after GIT checkout

GIT
checkout of Gnu Radio failed!

I looked at the shell script’s
line 1249 and I can see that it wants to access my sudoers file. Am I
suppose to change sudoers’ default permissions? This problem has been
frustrating me for a while especially considering I have successfully
installed GNU Radio on RHEL before. I appreciate any help on this
matter.

Thanks.

Jonathan F.

It’s never been
tested on Scientific Linux, and the RHEL support is only very lightly
tested–by exactly one person, as far as I know.

Are you running
this in a directory that you wouldn’t have write-access to if root? Like
an NFS mount maybe?


Discuss-gnuradio
mailing list

[email protected] [1]

https://lists.gnu.org/mailman/listinfo/discuss-gnuradio [2]

I tried
running it in /usr/local and /usr/local/src. Right now I am trying in
/home/$USER/workspace and I think that could of done the trick. I
suppose when it is done or if it finishes, I can move the source
directories to /usr/local/src.

This problem seems odd because I can
run this script in /usr/local on Ubuntu boxes but not in a RHEL clone.

Thanks for the response.

Jon

It’s intended to run in an
ordinary user directory – only only uses “sudo” for the final “make
install” and post-install stuff. Downloading and compiling code isn’t
something that requires root privilege, so those bits just run as an
ordinary user.

Possibly Ubuntu sets up /usr/local to be regular-user
writeable, but that would be a horrible security flaw.

Links:

On Thu, Mar 21, 2013 at 7:52 PM, Jonathan F.
[email protected]wrote:

I need to recheck the whole Ubuntu thing as soon as I get back to my lab.
Is the library path environment variable set correctly?
. /etc/bashrc
Oddly enough at the end of the build script I did not get the usual set
pythonpath message (around line 1219 in the buildscript). I am going to
test out the UHD driver tonight with an actual USRP.

Jon

Quick update. GRC started after I rebooted. I still need to check to see
if
everything runs without a hitch.

On Thu, Mar 21, 2013 at 4:29 AM, Martin L. [email protected] wrote:

Martin


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

I need to recheck the whole Ubuntu thing as soon as I get back to my
lab.

For my SL problem, I think it installed albeit without gnuradio
companion
working. I try to run “gnuradio-companion” in terminal and I get this
following error:

Cannot import gnuradio.

Is the python path environment variable set correctly?
All OS: PYTHONPATH

Is the library path environment variable set correctly?
Linux: LD_LIBRARY_PATH
Windows: PATH
MacOSX: DYLD_LIBRARY_PATH

I tried setting the paths in my .bashrc here:

.bashrc

Source global definitions

if [ -f /etc/bashrc ]; then
. /etc/bashrc
fi

User specific aliases and functions

library path for gnuradio

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib64

python path for gnuradio

export PYTHONPATH=$PYTHONPATH:/usr/local/lib64/python2.6/site-packages

Oddly enough at the end of the build script I did not get the usual set
pythonpath message (around line 1219 in the buildscript). I am going to
test out the UHD driver tonight with an actual USRP.

Jon

On 22 Mar 2013 09:26, Jonathan F. wrote:

On Thu, Mar 21, 2013
at 7:52 PM, Jonathan F. <[email protected] [4]> wrote:

On Thu, Mar 21, 2013 at 4:29 AM, Martin L. <[email protected] [3]>
wrote:

Possibly Ubuntu sets up /usr/local to be
regular-user

writeable, but that would be a horrible security
flaw.

At least for my Ubuntu 12.04 /usr/local is owned by
root:root with 0755

permissions and everything else would have given
me nightmares :wink:

Maybe you started the script with sudo,
instead of letting the script

itself call sudo, then you would have
had the necessary permissions.

Yours
Martin


Discuss-gnuradio
mailing list

[email protected] [1]

https://lists.gnu.org/mailman/listinfo/discuss-gnuradio [2]

I need to
recheck the whole Ubuntu thing as soon as I get back to my lab.

For my SL problem, I think it installed albeit without gnuradio
companion working. I try to run “gnuradio-companion” in terminal and I
get this following error:

Cannot import gnuradio.

Is the
python path environment variable set correctly?

All OS: PYTHONPATH

Is the library path environment variable set correctly?
Linux:
LD_LIBRARY_PATH

Windows: PATH
MacOSX: DYLD_LIBRARY_PATH

I
tried setting the paths in my .bashrc here:

.bashrc

Source global definitions

if [ -f /etc/bashrc ]; then
.
/etc/bashrc

fi

User specific aliases and functions

library path for gnuradio

export
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib64

python path

for gnuradio

export
PYTHONPATH=$PYTHONPATH:/usr/local/lib64/python2.6/site-packages

Oddly enough at the end of the build script I did not get the usual set
pythonpath message (around line 1219 in the buildscript). I am going to
test out the UHD driver tonight with an actual USRP.

Jon

Quick update. GRC started after I rebooted. I still need to check to see
if everything runs without a hitch.

Keep in mind that changes made to
your .bashrc only take effect the next time you log in, or the next time
you crack open a command window, but only if the command window tool is
configured to “run as login shell”.

Links:

[1]
mailto:[email protected]
[2]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
[3]
mailto:[email protected]
[4] mailto:[email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs