Build-gnuradio did not install gnuradio-runtime

Hello,

i have downloaded the Gnuradio repository with the script build-gnuradio
http://www.sbrac.org/files/build-gnuradio” on to the Fedora 19 and it
worked well.

Know I am trying to get install the project “IEEE802.15.4 transceiver
for GNU Radio v3.7”

From ccs-labs and I am getting the following Problem while running cmake
on the code.

I am very new with Gnu-Radio USRP, and unfortunately Linux (Fedora).

Problem:
“CMake Error at CMakeLists.txt:99 (message):
GnuRadio Runtime required to compile foo”

As much as I can see, I do not have the following gnuradio-runtime
component in my gnuradio folder that I installed with the build-gnuradio
script.

http://gnuradio.org/cgit/gnuradio.git/tree/gnuradio-runtime

Can I add this component separately to my directory without throwing
away my installation from the script?

I am very eager for responses.

Regards,
Dincer

This has been coming up in many other out-of-tree projects. Tom has
fixed
it in master. To fix it for gr-ieee802-15-4, take the latest
gnuradio/gr-utils/python/modtool/gr-newmod/cmake/Modules/FindGnuradioRuntime.cmake,
and copy it into the cmake/Modules directory of the out-of-tree module
you’re trying to compile. I don’t think Bastian’s custom gnuradio repo
has
this patch yet, so use the latest master branch of the official git
repo,
or apply the attached patch.

–n

diff --git
a/gr-utils/python/modtool/gr-newmod/cmake/Modules/FindGnuradioRuntime.cmake
b/gr-utils/python/modtool/gr-newmod/cmake/Modules/FindGnuradioRuntime.cmake
index 99a4a6d…2833fb1 100644
@@ -1,5 +1,34 @@
INCLUDE(FindPkgConfig)
-PKG_CHECK_MODULES(GNURADIO_RUNTIME gnuradio-runtime)
+PKG_CHECK_MODULES(PC_GNURADIO_RUNTIME gnuradio-runtime)
+
+if(PC_GNURADIO_RUNTIME_FOUND)

  • look for include files

  • FIND_PATH(
  • GNURADIO_RUNTIME_INCLUDE_DIRS
  • NAMES gnuradio/top_block.h
  • HINTS $ENV{GNURADIO_RUNTIME_DIR}/include
  •      ${PC_GNURADIO_RUNTIME_INCLUDE_DIRS}
    
  •      ${CMAKE_INSTALL_PREFIX}/include
    
  • PATHS /usr/local/include
  •      /usr/include
    
  • )
  • look for libs

  • FIND_LIBRARY(
  • GNURADIO_RUNTIME_LIBRARIES
  • NAMES gnuradio-runtime
  • HINTS $ENV{GNURADIO_RUNTIME_DIR}/lib
  •      ${PC_GNURADIO_RUNTIME_LIBDIR}
    
  •      ${CMAKE_INSTALL_PREFIX}/lib/
    
  •      ${CMAKE_INSTALL_PREFIX}/lib64/
    
  • PATHS /usr/local/lib
  •      /usr/local/lib64
    
  •      /usr/lib
    
  •      /usr/lib64
    
  • )
  • set(GNURADIO_RUNTIME_FOUND ${PC_GNURADIO_RUNTIME_FOUND})
    +endif(PC_GNURADIO_RUNTIME_FOUND)

INCLUDE(FindPackageHandleStandardArgs)
FIND_PACKAGE_HANDLE_STANDARD_ARGS(GNURADIO_RUNTIME DEFAULT_MSG
GNURADIO_RUNTIME_LIBRARIES GNURADIO_RUNTIME_INCLUDE_DIRS)

Hi,

On 09/16/2013 06:09 PM, Nick F. wrote:

This has been coming up in many other out-of-tree projects. Tom has
fixed it in master. To fix it for gr-ieee802-15-4, take the latest

gnuradio/gr-utils/python/modtool/gr-newmod/cmake/Modules/FindGnuradioRuntime.cmake,

and copy it into the cmake/Modules directory of the out-of-tree module
you’re trying to compile. I don’t think Bastian’s custom gnuradio repo
has this patch yet, so use the latest master branch of the official git
repo, or apply the attached patch.

–n

thanks for pointing to that commit.
I am not able to reproduce the error, but I installed current next
branch, created an OOT module with gr_modtool, and copied
FindGnuradioRuntime.cmake.

I can just say that it still works for me :slight_smile:

Hopefully this fixes your problem.

Best,
Bastian

Hello Nick, Hello Bastian,

I again have a question regarding the gr-ieee802-15-4 (gr-foo) project.

As I mentioned before, I downloaded the GnuRadio from Bastibl’s Git and
run a successful cmake and make (excluding some components with DENABLE
like the fcd).

Since I did not have the issue of the FindGnuradioRuntime.cmake while
running the cmake in the gr-ieee802-15-4, I did not changed any .cmake
files in the gr-ieee802-15-4 folder.

When I am running the gr-foo make to build the files, I get the
following error. Obviously it is a linking issue, but do I need to add a
library or some other dependency? I already have all the dependencies
from the Ubuntu 10.04 version and build the gnuradio successfully. What
lib or file should I link? Should I use a specific compiler/linker?

All the errors in the source file, give me the impression of a syntax
error.

[email protected]:/home/openwns/GnuRadioBastian/gr-foo/build# make
[ 4%] Building CXX object
lib/CMakeFiles/gnuradio-foo.dir/packet_dropper_impl.cc.o
In file included from
/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.cc:18:
/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.h:28:
error: ‘default_random_engine’ in namespace ‘std’ does not name a type
/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.h:29:
error: ISO C++ forbids declaration of ‘uniform_real_distribution’ with
no type
/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.h:29:
error: invalid use of ‘::’
/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.h:29:
error: expected ‘;’ before ‘<’ token
/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.cc: In
constructor ‘gr::foo::packet_dropper_impl::packet_dropper_impl(double,
long unsigned int)’:
/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.cc:28:
error: class ‘gr::foo::packet_dropper_impl’ does not have any field
named ‘d_generator’
/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.cc:29:
error: class ‘gr::foo::packet_dropper_impl’ does not have any field
named ‘d_distribution’
/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.cc: In
member function ‘void
gr::foo::packet_dropper_impl::msg_handler(pmt::pmt_t)’:
/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.cc:42:
error: ‘d_generator’ was not declared in this scope
/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.cc:42:
error: ‘d_distribution’ was not declared in this scope
make[2]: *** [lib/CMakeFiles/gnuradio-foo.dir/packet_dropper_impl.cc.o]
Fehler 1
make[1]: *** [lib/CMakeFiles/gnuradio-foo.dir/all] Fehler 2
make: *** [all] Fehler 2

The gr-ieee802-15-4 also gives errors at make, but before solving this,
I don’t want to bother myself with that.

Thanks,
Dincer

Von: Nick F. [mailto:[email protected]]
Gesendet: Montag, 16. September 2013 18:09
An: Dincer B.
Cc: [email protected]; [email protected]
Betreff: Re: [Discuss-gnuradio] build-gnuradio did not install
gnuradio-runtime

This has been coming up in many other out-of-tree projects. Tom has
fixed it in master. To fix it for gr-ieee802-15-4, take the latest
gnuradio/gr-utils/python/modtool/gr-newmod/cmake/Modules/FindGnuradioRuntime.cmake,
and copy it into the cmake/Modules directory of the out-of-tree module
you’re trying to compile. I don’t think Bastian’s custom gnuradio repo
has this patch yet, so use the latest master branch of the official git
repo, or apply the attached patch.

–n

diff --git
a/gr-utils/python/modtool/gr-newmod/cmake/Modules/FindGnuradioRuntime.cmake
b/gr-utils/python/modtool/gr-newmod/cmake/Modules/FindGnuradioRuntime.cmake
index 99a4a6d…2833fb1 100644
@@ -1,5 +1,34 @@
INCLUDE(FindPkgConfig)
-PKG_CHECK_MODULES(GNURADIO_RUNTIME gnuradio-runtime)
+PKG_CHECK_MODULES(PC_GNURADIO_RUNTIME gnuradio-runtime)
+
+if(PC_GNURADIO_RUNTIME_FOUND)

  • look for include files

  • FIND_PATH(
  • GNURADIO_RUNTIME_INCLUDE_DIRS
  • NAMES gnuradio/top_block.h
  • HINTS $ENV{GNURADIO_RUNTIME_DIR}/include
  •      ${PC_GNURADIO_RUNTIME_INCLUDE_DIRS}
    
  •      ${CMAKE_INSTALL_PREFIX}/include
    
  • PATHS /usr/local/include
  •      /usr/include
    
  • )
  • look for libs

  • FIND_LIBRARY(
  • GNURADIO_RUNTIME_LIBRARIES
  • NAMES gnuradio-runtime
  • HINTS $ENV{GNURADIO_RUNTIME_DIR}/lib
  •      ${PC_GNURADIO_RUNTIME_LIBDIR}
    
  •      ${CMAKE_INSTALL_PREFIX}/lib/
    
  •      ${CMAKE_INSTALL_PREFIX}/lib64/
    
  • PATHS /usr/local/lib
  •      /usr/local/lib64
    
  •      /usr/lib
    
  •      /usr/lib64
    
  • )
  • set(GNURADIO_RUNTIME_FOUND ${PC_GNURADIO_RUNTIME_FOUND})
    +endif(PC_GNURADIO_RUNTIME_FOUND)

INCLUDE(FindPackageHandleStandardArgs)
FIND_PACKAGE_HANDLE_STANDARD_ARGS(GNURADIO_RUNTIME DEFAULT_MSG
GNURADIO_RUNTIME_LIBRARIES GNURADIO_RUNTIME_INCLUDE_DIRS)

On Mon, Sep 16, 2013 at 7:58 AM, Dincer B.
<[email protected]mailto:[email protected]> wrote:
Hello,

i have downloaded the Gnuradio repository with the script build-gnuradio
http://www.sbrac.org/files/build-gnuradio” on to the Fedora 19 and it
worked well.

Know I am trying to get install the project “IEEE802.15.4 transceiver
for GNU Radio v3.7”

From ccs-labs and I am getting the following Problem while running cmake
on the code.

I am very new with Gnu-Radio USRP, and unfortunately Linux (Fedora).

Problem:
“CMake Error at CMakeLists.txt:99 (message):
GnuRadio Runtime required to compile foo”

As much as I can see, I do not have the following gnuradio-runtime
component in my gnuradio folder that I installed with the build-gnuradio
script.

http://gnuradio.org/cgit/gnuradio.git/tree/gnuradio-runtime

Can I add this component separately to my directory without throwing
away my installation from the script?

I am very eager for responses.

Regards,
Dincer

Hi,

On 09/17/2013 10:19 AM, Dincer B. wrote:

/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.h:29:
error: class gr::foo::packet_dropper_impl does not have any field
make[1]: *** [lib/CMakeFiles/gnuradio-foo.dir/all] Fehler 2
make: *** [all] Fehler 2

hmmm, maybe that’s because is not included. For me it works
anyhow. I just added it, maybe you want to give it a try with:

git pull origin master

and then make again.

Sorry for these annoying bugs,
Bastian

Hi all,

so I have installed Bastian’s Gnu Radio and could build the files. I
have not changed the FindGnuradioRuntime.cmake, because when I ran the
cmake with Bastian’s Project there were no errors, and to be honest, I
don’t know if I need to overwrite it still (although Make for
gr-ieee802-15-14 crashed).

Right now, I don’t have anything to do with Bastian’s Projekt but still
having trouble with the Gnuradio Code.

When I run a make test I got a %2 error rate with

  • qa_fir_filter_test
  • qa_freq_xlating_fir_filter_test
  • qa_ctcss_squelch
  • qa_codec2_covocoder

Tests failing.

I am running a 32 Bit Ubuntu 10.04

For the first 3 tests I got a similar error (only the values change), so
I think that they are a related issue of the data structures:

84: Test command: /bin/sh
/home/openwns/GnuRadioBastian/gnuradio/build/gr-filter/python/filter/qa_fir_filter_test.sh
84: Test timeout computed to be: 9.99988e+06
84: …FF
84:

84: FAIL: test_fir_filter_scc_001 (main.test_filter)
84:

84: Traceback (most recent call last):
84: File
“/home/openwns/GnuRadioBastian/gnuradio/gr-filter/python/filter/qa_fir_filter.py”,
line 260, in test_fir_filter_scc_001
84: self.assertComplexTuplesAlmostEqual(expected_data, result_data,
5)
84: File
“/home/openwns/GnuRadioBastian/gnuradio/gnuradio-runtime/python/gnuradio/gr_unittest.py”,
line 74, in assertComplexTuplesAlmostEqual
84: self.assertComplexAlmostEqual (a[i], b[i], places, msg)
84: File
“/home/openwns/GnuRadioBastian/gnuradio/gnuradio-runtime/python/gnuradio/gr_unittest.py”,
line 47, in assertComplexAlmostEqual
84: (msg or ‘%s != %s within %s places’ % (first, second,
places ))
84: AssertionError: (0.5+1j) != (nan+nan*j) within 5 places
84:
84:

84: FAIL: test_fir_filter_scc_002 (main.test_filter)
84:

84: Traceback (most recent call last):
84: File
“/home/openwns/GnuRadioBastian/gnuradio/gr-filter/python/filter/qa_fir_filter.py”,
line 279, in test_fir_filter_scc_002
84: self.assertComplexTuplesAlmostEqual(expected_data, result_data,
5)
84: File
“/home/openwns/GnuRadioBastian/gnuradio/gnuradio-runtime/python/gnuradio/gr_unittest.py”,
line 74, in assertComplexTuplesAlmostEqual
84: self.assertComplexAlmostEqual (a[i], b[i], places, msg)
84: File
“/home/openwns/GnuRadioBastian/gnuradio/gnuradio-runtime/python/gnuradio/gr_unittest.py”,
line 47, in assertComplexAlmostEqual
84: (msg or ‘%s != %s within %s places’ % (first, second,
places ))
84: AssertionError: (0.5+1j) != (nan+nan*j) within 5 places
84:
84:

84: Ran 11 tests in 0.040s
84:
84: FAILED (failures=2)
84: Using Volk machine: sse4_a_32
1/1 Test #84: qa_fir_filter …***Failed 1.06 sec

0% tests passed, 1 tests failed out of 1

Total Test time (real) = 1.14 sec

The following tests FAILED:
84 - qa_fir_filter (Failed)
Errors while running CTest

For the last test qa_codec2_vocoder I got the following error message:

[email protected]:/home/openwns/GnuRadioBastian/gnuradio/build# ctest
-V -R qa_codec2_vocoder
UpdateCTestConfiguration from
:/home/openwns/GnuRadioBastian/gnuradio/build/DartConfiguration.tcl
UpdateCTestConfiguration from
:/home/openwns/GnuRadioBastian/gnuradio/build/DartConfiguration.tcl
Test project /home/openwns/GnuRadioBastian/gnuradio/build
Constructing a list of tests
Done constructing a list of tests
Checking test dependency graph…
test 166
Start 166: qa_codec2_vocoder

166: Test command: /bin/sh
/home/openwns/GnuRadioBastian/gnuradio/build/gr-vocoder/python/vocoder/qa_codec2_vocoder_test.sh
166: Test timeout computed to be: 9.99988e+06
166: F
166:

166: FAIL: test001_module_load (main.test_codec2_vocoder)
166:

166: Traceback (most recent call last):
166: File
“/home/openwns/GnuRadioBastian/gnuradio/gr-vocoder/python/vocoder/qa_codec2_vocoder.py”,
line 54, in test001_module_load
166: self.assertEqual(expected_data, actual_result)
166: AssertionError: (0, 0, 0, 3, 2, 0, 1, 5, 6, 7, 1, -1, 0, -5, -11,
-10, -20, -22, -20, -20, -27, -26, -36, -48, -59, -24, 5, -7, -12, -27,
-22, -22, -16, 13, 20, 39, 23, 25, 8, -6, 15, 44, 97, 135, 145, 125, 94,
102, 126, 129, 165, 192, 180, 132, 99, 79, 73, 83, 72, 47, 40, 0, -32,
-46, -67, -99, -123, -114, -87, -108, -131, -152, -181, -245, -348,
-294, -101, -71, -85, -26, 99, 123, 15, 2, 77, 13, -117, -145, -105,
-39, -50, -89, -59, -77, -134, -95, -51, -22, 17, -19, -59, -74, -103,
-78, 4, 77, 113, 60, 18, 13, -67, -49, 24, 88, 179, 190, 89, 18, -90,
-102, -50, -5, 123, 135, 57, 31, -82, -98, -51, 6, 93, 104, 44, -5, -84,
-107, -44, 45, 102, 104, 15, -47, -107, -126, -87, -11, 89, 93, 13, -95,
-136, -187, -70, -167, 216, -70, -103, 175, -284, -486) != (0, 0, 0, 3,
2, 0, 1, 5, 6, 7, 1, -1, 0, -5, -11, -10, -20, -22, -20, -20, -27, -26,
-36, -48, -59, -24, 5, -7, -12, -27, -22, -22, -16, 13, 20, 39, 23, 25,
8, -6, 15, 44, 97, 135, 145, 125, 94, 102, 126, 129, 165, 192, 180, 132,
99, 79, 73, 83, 72, 47, 40, 0, -32, -46, -67, -99, -123, -114, -87,
-108, -131, -152, -181, -245, -348, -294, -101, -71, -85, -26, 99, 123,
15, 2, 77, 13, -117, -145, -105, -39, -50, -89, -59, -77, -134, -95,
-51, -22, 17, -19, -59, -74, -103, -78, 4, 77, 113, 60, 18, 13, -67,
-49, 25, 88, 179, 190, 89, 18, -90, -102, -50, -5, 123, 135, 57, 31,
-82, -98, -51, 6, 93, 104, 44, -5, -84, -107, -44, 45, 102, 104, 15,
-47, -107, -126, -87, -11, 89, 93, 13, -96, -136, -187, -70, -167, 216,
-70, -103, 175, -284, -486)
166:
166:

166: Ran 1 test in 0.004s
166:
166: FAILED (failures=1)
1/1 Test #166: qa_codec2_vocoder …***Failed 0.82 sec

0% tests passed, 1 tests failed out of 1

Total Test time (real) = 0.88 sec

The following tests FAILED:
166 - qa_codec2_vocoder (Failed)

Unfortunately, I couldn’t look in it in detail because I have the
feeling it is a kind of a generic floating point issue.

Could anyone help me fixing this?
And to Nick and Bastian: do I still need to change
FindGnuradioRuntime.cmake??

Every help appreciated,
Dincer

-----Ursprngliche Nachricht-----
Von: Bastian B. [mailto:[email protected]]
Gesendet: Montag, 16. September 2013 19:47
An: Nick F.
Cc: Dincer B.; [email protected]
Betreff: Re: [Discuss-gnuradio] build-gnuradio did not install
gnuradio-runtime

Hi,

On 09/16/2013 06:09 PM, Nick F. wrote:

This has been coming up in many other out-of-tree projects. Tom has
fixed it in master. To fix it for gr-ieee802-15-4, take the latest
gnuradio/gr-utils/python/modtool/gr-newmod/cmake/Modules/FindGnuradioR
untime.cmake, and copy it into the cmake/Modules directory of the
out-of-tree module you’re trying to compile. I don’t think Bastian’s
custom gnuradio repo has this patch yet, so use the latest master
branch of the official git repo, or apply the attached patch.

–n

thanks for pointing to that commit.
I am not able to reproduce the error, but I installed current next
branch, created an OOT module with gr_modtool, and copied
FindGnuradioRuntime.cmake.

I can just say that it still works for me :slight_smile:

Hopefully this fixes your problem.

Best,
Bastian

On Tue, Sep 17, 2013 at 3:43 AM, Dincer B. [email protected]
wrote:

  • qa_ctcss_squelch
  • qa_codec2_covocoder

Hi Dincer,

Ignore the CTCSS and CODEC2 problems. There’s some architecture issues
involved there that we haven’t been able to track down, but the QA
code failing isn’t a problem unless you are specifically using those
blocks.

The FIR filter tests are likely VOLK related. Again, this seems to be
an architecture thing. Though I think if we plotted the histograms,
there is only a partial overlap between these failures and the other
two. I’ve never been able to generate these errors on any of my
machines of VMs and so haven’t had a chance to look into what’s going
on here.

Try running ‘volk_profile’ and waiting for that to complete. You
should be ok running applications after that, at least.


Tom
Visit us at GRCon13 Oct. 1 - 4
http://www.trondeau.com/grcon13

On 09/17/2013 10:19 AM, Dincer B. wrote:

/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.h:29:
error: class gr::foo::packet_dropper_impl does not have any field
make[1]: *** [lib/CMakeFiles/gnuradio-foo.dir/all] Fehler 2
make: *** [all] Fehler 2

Meanwhile we figured out its a compile problem… I use some C++11 stuff
and this does not work with g++ v4.4 :-/

On Tue, Sep 17, 2013 at 10:26 AM, Dincer B. [email protected]
wrote:

Hi Tom,

I was using AMD Processors, now I am installing GnuRadio (build-GnuRadio -m) v
3.7 on a Intel proc.
I hope the problem will vanish.

I have no idea what could else be the problem…
I am using a 64 bit system

Regards,
Dincer

Let us know how those test work/fail on the Intel-based system. If
it’s an AMD problem, I’m going to have to see about getting my hands
on an AMD system temporarily to see if I can figure out these bugs.

Hi Tom,

I was using AMD Processors, now I am installing GnuRadio (build-GnuRadio
-m) v 3.7 on a Intel proc.
I hope the problem will vanish.

I have no idea what could else be the problem…
I am using a 64 bit system

Regards,
Dincer

-----Ursprngliche Nachricht-----
Von: [email protected] [mailto:[email protected]] Im Auftrag von
Tom R.
Gesendet: Dienstag, 17. September 2013 16:13
An: Dincer B.
Cc: [email protected]
Betreff: Re: [Discuss-gnuradio] build-gnuradio did not install
gnuradio-runtime

On Tue, Sep 17, 2013 at 3:43 AM, Dincer B. [email protected]
wrote:

  • qa_ctcss_squelch
  • qa_codec2_covocoder

Hi Dincer,

Ignore the CTCSS and CODEC2 problems. There’s some architecture issues
involved there that we haven’t been able to track down, but the QA code
failing isn’t a problem unless you are specifically using those blocks.

The FIR filter tests are likely VOLK related. Again, this seems to be an
architecture thing. Though I think if we plotted the histograms, there
is only a partial overlap between these failures and the other two. I’ve
never been able to generate these errors on any of my machines of VMs
and so haven’t had a chance to look into what’s going on here.

Try running ‘volk_profile’ and waiting for that to complete. You should
be ok running applications after that, at least.


Tom
Visit us at GRCon13 Oct. 1 - 4
http://www.trondeau.com/grcon13

Hi Tom,

How important is qa_qtgui?
This is the result of the make test for Fedora 19 on Intel 64 Bit.
(second run). So qa_fir crashing (see below) is an AMD issue…

99% tests passed, 1 tests failed out of 176

Total Test time (real) = 112.33 sec

The following tests FAILED:
163 - qa_qtgui (Failed)
Errors while running CTest
make: *** [test] Error 8
[[email protected] build]$


This was the first run:

Total Test time (real) = 122.63 sec

The following tests FAILED:
146 - qa_pfb_clock_sync (Failed)
152 - qa_constellation_receiver (Failed)
163 - qa_qtgui (Failed)
Errors while running CTest
make: *** [test] Error 8
[[email protected] build]$ make test

QUESTION: How important is qa_qtgui?

-----Ursprngliche Nachricht-----
Von: [email protected] [mailto:[email protected]] Im Auftrag von
Tom R.
Gesendet: Dienstag, 17. September 2013 16:13
An: Dincer B.
Cc: [email protected]
Betreff: Re: [Discuss-gnuradio] build-gnuradio did not install
gnuradio-runtime

On Tue, Sep 17, 2013 at 3:43 AM, Dincer B. [email protected]
wrote:

  • qa_ctcss_squelch
  • qa_codec2_covocoder

Hi Dincer,

Ignore the CTCSS and CODEC2 problems. There’s some architecture issues
involved there that we haven’t been able to track down, but the QA code
failing isn’t a problem unless you are specifically using those blocks.

The FIR filter tests are likely VOLK related. Again, this seems to be an
architecture thing. Though I think if we plotted the histograms, there
is only a partial overlap between these failures and the other two. I’ve
never been able to generate these errors on any of my machines of VMs
and so haven’t had a chance to look into what’s going on here.

Try running ‘volk_profile’ and waiting for that to complete. You should
be ok running applications after that, at least.


Tom
Visit us at GRCon13 Oct. 1 - 4
http://www.trondeau.com/grcon13

Hi,

so i installed a Fedora 19 with build-gnuradio -m. (Yes I used the
official GnuRadio :(( ).

I ran a cmake … with Bastians new cmake files (both for gr-foo &
gr-ieee802-15-4).

It did not work. So it really does not work with the official repo, even
if you change FindGnuRadioRuntime.cmake with the original (I tried it
twice):

http://gnuradio.org/cgit/gnuradio.git/tree/gr-utils/python/modtool/gr-newmod/cmake/Modules/FindGnuradioRuntime.cmake?id=3.7.2git
Error:

[[email protected] build]$ cmake …/
– Build type not specified: defaulting to release.
– Boost version: 1.53.0
– Found the following Boost libraries:
– filesystem
– system
– Found PkgConfig: /usr/bin/pkg-config (found version “0.27.1”)
– checking for module ‘gnuradio-runtime’
– package ‘gnuradio-runtime’ not found
– Could NOT find GNURADIO_RUNTIME (missing:
GNURADIO_RUNTIME_LIBRARIES)
– checking for module ‘cppunit’
– found cppunit, version 1.12.1
– Found CPPUNIT: /usr/lib64/libcppunit.so;dl
CMake Error at CMakeLists.txt:87 (message):
GnuRadio Runtime required to compile ieee802-11

– Configuring incomplete, errors occurred!
[[email protected] build]$

I will try (for the last time) to run on a new and different Fedora
Bastian’s GnuRadio.

Regards,
Dincer

-----Ursprngliche Nachricht-----
Von: Bastian B. [mailto:[email protected]]
Gesendet: Dienstag, 17. September 2013 16:19
An: Dincer B.
Cc: Nick F.; [email protected]
Betreff: Re: [Discuss-gnuradio] build-gnuradio did not install
gnuradio-runtime

On 09/17/2013 10:19 AM, Dincer B. wrote:

/home/openwns/GnuRadioBastian/gr-foo/lib/packet_dropper_impl.h:29:
error: class ‘gr::foo::packet_dropper_impl’ does not have any field
Fehler 1
make[1]: *** [lib/CMakeFiles/gnuradio-foo.dir/all] Fehler 2
make: *** [all] Fehler 2

Meanwhile we figured out its a compile problem… I use some C++11 stuff
and this does not work with g++ v4.4 :-/

On Tue, Sep 17, 2013 at 10:13 AM, Tom R. [email protected] wrote:

having trouble with the Gnuradio Code.
Ignore the CTCSS and CODEC2 problems. There’s some architecture issues

Try running ‘volk_profile’ and waiting for that to complete. You
should be ok running applications after that, at least.

Hi All,

volk_profile writes a file volk_config to a directory that isn’t the
path
for the gnuradio installation. Should this file be copied elsewhere? The
qa_volk_test_all fails on volk_32fc_s32f_magnitude_16i_test even after
running volk_profile.

Should I create a separate thread with all the information related to my
failing tests, and post all the information (environment, etc) there?

Best,
Aditya

On Tue, Sep 17, 2013 at 12:15 PM, Dincer B. [email protected]
wrote:

    163 - qa_qtgui (Failed)
    146 - qa_pfb_clock_sync (Failed)
    152 - qa_constellation_receiver (Failed)
    163 - qa_qtgui (Failed)

Errors while running CTest
make: *** [test] Error 8
[[email protected] build]$ make test

QUESTION: How important is qa_qtgui?

Depends on if you want to use QTGUI. Are you running a X server or are
you just working in a console? The only times I’ve seen QTGUI build
but fail QA is if you are remoted in over SSH and not forwarding X (or
if the remote isn’t running X). All that QA does is try to create
QTGUI sink objects but not actually run them.

So if you’re not interested in the GUI sinks, then QTGUI is not
important and should probably be disabled during cmake.


Tom
Visit us at GRCon13 Oct. 1 - 4
http://www.trondeau.com/grcon13

On Tue, Sep 17, 2013 at 12:18 PM, Dincer B. [email protected]
wrote:

twice):
– system

-----Ursprngliche Nachricht-----

lib/CMakeFiles/gnuradio-foo.dir/packet_dropper_impl.cc.o
error: expected ‘;’ before ‘<’ token
member function 'void

Meanwhile we figured out its a compile problem… I use some C++11 stuff
and this does not work with g++ v4.4 :-/

Hi All,

I was facing a similar same issue (tests failing). I used to run 32-bit
Ubuntu Linux (13.04) on 64-bit hardware. I ran the stock unmodified
gnuradio that was installed from source, which was in turn downloaded
from
the GIT repo. I tried everything that was suggested on the mailing list
archives – including running volk_profile, etc, but the tests kept
failing.

I then installed 64-bit Linux (Ubuntu 12.04 LTS), installed the latest
version of ORC (0.4.18), re-installed gnuradio and tried again. All
tests
now pass
(other than vocoder).

Just thought I’d let you know in case anyone is facing the same issue.

Best regards,
Aditya

I just wanted to give an update. It was resolved 2 weeks ago but I
forgot to post it.

Bastian’s Project works fine with Ubuntu 12.04. For a Linux dummy, if
you install Bastians GNU Radio Version on a new Linux dist. It works
fine.
You can use Bastians GRadio also for other projects, it does not look
like it is limiting anything. All the blocks also work fine.

Von: [email protected]alid
[mailto:[email protected]alid] Im Auftrag
von Aditya D.
Gesendet: Dienstag, 17. September 2013 18:21
An: [email protected]
Betreff: Re: [Discuss-gnuradio] build-gnuradio did not
installgnuradio-runtime

On Tue, Sep 17, 2013 at 10:13 AM, Tom R.
<[email protected]mailto:[email protected]> wrote:
On Tue, Sep 17, 2013 at 3:43 AM, Dincer B.
<[email protected]mailto:[email protected]> wrote:

  • qa_ctcss_squelch
  • qa_codec2_covocoder
    Hi Dincer,

Ignore the CTCSS and CODEC2 problems. There’s some architecture issues
involved there that we haven’t been able to track down, but the QA
code failing isn’t a problem unless you are specifically using those
blocks.

The FIR filter tests are likely VOLK related. Again, this seems to be
an architecture thing. Though I think if we plotted the histograms,
there is only a partial overlap between these failures and the other
two. I’ve never been able to generate these errors on any of my
machines of VMs and so haven’t had a chance to look into what’s going
on here.

Try running ‘volk_profile’ and waiting for that to complete. You
should be ok running applications after that, at least.

Hi All,

volk_profile writes a file volk_config to a directory that isn’t the
path for the gnuradio installation. Should this file be copied
elsewhere? The qa_volk_test_all fails on
volk_32fc_s32f_magnitude_16i_test even after running volk_profile.

Should I create a separate thread with all the information related to my
failing tests, and post all the information (environment, etc) there?

Best,
Aditya

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs