Build error on cygwin

I am trying to install ruby1.8.4

./configure --prefix=/pool/installed2 --disable-nls
make

make[1]: Leaving directory
/pool/software/ruby/ruby-1.8.4/ext/enumerator' compiling etc /pool/software/ruby/ruby-1.8.4/lib/mkmf.rb:174:ininitialize’:
Permission denie
d - mkmftmp1.log (Errno::EACCES)
from /pool/software/ruby/ruby-1.8.4/lib/mkmf.rb:174:in open' from /pool/software/ruby/ruby-1.8.4/lib/mkmf.rb:205:inpostpone’
from /pool/software/ruby/ruby-1.8.4/lib/mkmf.rb:178:in open' from /pool/software/ruby/ruby-1.8.4/lib/mkmf.rb:201:inpostpone’
from /pool/software/ruby/ruby-1.8.4/lib/mkmf.rb:541:in
checking_for' from /pool/software/ruby/ruby-1.8.4/lib/mkmf.rb:669:inhave_type’
from …/…/./ext/etc/extconf.rb:27
from ./ext/extmk.rb:138:in `extmake’
from ./ext/extmk.rb:397
from ./ext/extmk.rb:396
make: *** [all] Error 1

does someone know what may be going wrong?

Thanks in advance

Schüle Daniel wrote:

/pool/software/ruby/ruby-1.8.4/lib/mkmf.rb:174:in `initialize’:
from …/…/./ext/etc/extconf.rb:27
Daniel

Do you just need Ruby on CygWin, or do you need to build it from source?
My copy of CygWin (I install the whole thing) has Ruby 1.8.4 as part of
the distribution. I don’t know why building Ruby from source would
break, though.

M. Edward (Ed) Borasky wrote:

compiling etc
/pool/software/ruby/ruby-1.8.4/lib/mkmf.rb:174:in `initialize’:
Permission denie
d - mkmftmp1.log (Errno::EACCES)

Oops … didn’t see that. It looks like you don’t have enough privileges
to “install” software. You probably need to be what Windows calls a
“Power User” or an “Administrator” to run this. Check with your IT folks
if you aren’t the Administrator of your system. Meanwhile, you can use
the binary Ruby that comes with CygWin.

Hi,

At Sun, 30 Jul 2006 06:50:05 +0900,
Schüle Daniel wrote in [ruby-talk:204932]:

if you aren’t the Administrator of your system. Meanwhile, you can use
the binary Ruby that comes with CygWin.

actually I am logged in as administrator on XP
but you are right if I recall properly “whoami” under
cygwin said I am not the “root”

It occurs at compile time, not installation. The privileges
are not needed for compilation even on Unixes. Check if
ext/etc directory is read-only and/or there is a read-only file
named mkmftmp1.log under it.

I will try to “su root” next time I boot into XP

su doesn’t work on cygwin, as you can see immediately if you
run it. It tells to use runas instead.

hi,

[…]

if you aren’t the Administrator of your system. Meanwhile, you can use
the binary Ruby that comes with CygWin.

actually I am logged in as administrator on XP
but you are right if I recall properly “whoami” under
cygwin said I am not the “root”

[…]

Do you just need Ruby on CygWin, or do you need to build it from
source? My copy of CygWin (I install the whole thing) has Ruby 1.8.4
as part of the distribution. I don’t know why building Ruby from
source would break, though.

yes, ruby is a part of the distribution
there seems to be a problem with irb (it doesn’t start)
that’s why I am trying to install it from sources
most of the time I am working on my Linux box and I simply like to
build software I use from sources :slight_smile:

I will try to “su root” next time I boot into XP

Regrads, Daniel

N Okia wrote:

to reinstall cygwin?

I just tried “irb” on CygWin and it spake thusly:

$ irb
/usr/bin/ruby: no such file to load – ubygems (LoadError)

I think CygWin is broken! Is this what it’s doing on your system??

M. Edward (Ed) Borasky wrote:

I just tried “irb” on CygWin and it spake thusly:

$ irb
/usr/bin/ruby: no such file to load – ubygems (LoadError)

I think CygWin is broken! Is this what it’s doing on your system??

Try unsetting your RUBYOPT or installing rubygems (which has
an actual lib called “ubygems”).

Hal

On 7/29/06, Schüle Daniel [email protected] wrote:

yes, ruby is a part of the distribution
there seems to be a problem with irb (it doesn’t start)
that’s why I am trying to install it from sources
most of the time I am working on my Linux box and I simply like to
build software I use from sources :slight_smile:

That’s very odd. I’ve installed Cygwin with Ruby on several Win XP
machines, and never had any problems with ruby or irb. Maybe you need
to reinstall cygwin?

I have seen that, and usually you need to unset RUBYOPT. The problem
usually occurs because you have both cygwin and One-Click Ruby
installer.

Hal F. wrote:

Hal

Yep … first undefine RUBYOPT, then re-install rubygems, then re-set
RUBYOPT and irb still works. I do have the one-click installer loaded,
and CygWin inherited the RUBYOPT definition from Windows. This is
apparently an FAQ. :slight_smile:

[…]

I just tried “irb” on CygWin and it spake thusly:

$ irb
/usr/bin/ruby: no such file to load – ubygems (LoadError)

I think CygWin is broken! Is this what it’s doing on your system??

yes, this is what it says
I don’t think cygwin is broken, most probably just misconfiguration
of ruby package(?)

Regards, Daniel

Schüle Daniel wrote:

I don’t think cygwin is broken, most probably just misconfiguration
of ruby package(?)

Regards, Daniel

The fix was posted. What was happening on my system was that I installed
the One-Click Installer. It sets a Windows-level environment variable
RUBYOPT. The CygWin command line inherits this setting from Windows. And
that setting confuses irb.

So you have to unset RUBYOPT in the CygWin command line, and then
install or reinstall rubygems. Then irb works.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs