Bugs - Win Build


#1

This may have been posted already, sorry if it has - disregard in such
case.

OS: vista x64

  1. Using fastcgi or proxy cache systems cause immediate crash upon
    start.
  2. Setting worker_processes higher than 1 causes server stall on
    secondary load testing through ab.

ie.
Command: ab -n 5000 -c 25 -k http://localhost
Run 1:
Results: … Finished 5000 requests

Run 2: Hangs until ab decides to give up.

Keep up the good work.

  • Dusty

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,1803,1803#msg-1803


#2

On Wed, May 06, 2009 at 11:21:54AM -0400, Trigun wrote:

This may have been posted already, sorry if it has - disregard in such case.

OS: vista x64

  1. Using fastcgi or proxy cache systems cause immediate crash upon start.

I can not reproduce it on 32-bit Windows Server 2003.
Could you ensure that this is x64 problem only ?

  1. Setting worker_processes higher than 1 causes server stall on secondary load testing through ab.

ie.
Command: ab -n 5000 -c 25 -k http://localhost
Run 1:
Results: … Finished 5000 requests

Run 2: Hangs until ab decides to give up.

It seems like Winsock bug. It sends new connection notifications
to a single process only.


#3

Yes sir, I have a crash dump as well… although without debugging
symbols… not sure how much use it will be.
Unhandled exception at 0x00436a3b in nginx.dmp: 0xC0000005: Access
violation reading location 0x02948068.

http://www.flyupload.com/?fid=988885893

This is my current simple config, notice a lot of stuff is commented
out… obviously from trying to locate the cause of the crash.
Uncommenting the proxy_cache_path or fastcgi_cache_path trigger the
crash.

#user nobody
#pid logs/nginx.pid;
#error_log logs/error.log
#error_log logs/error.log notice;
#error_log logs/error.log info;
worker_processes 1;
events {
worker_connections 1024;
}

http {
include mime.types;

access_log off;

sendfile on;
keepalive_timeout 5;

gzip on;
gzip_comp_level 1;
gzip_types text/plain text/css text/xml application/x-javascript
application/rss+xml;

#proxy_cache_path E:/Server/httpd/cache/proxy_cache levels=1:2
keys_zone=php:10m inactive=30m max_size=25m;
#proxy_temp_path E:/Server/httpd/temp/proxy_temp 1 2;
#fastcgi_cache_path E:/Server/httpd/cache/fastcgi_cache levels=1:2
keys_zone=php:10m inactive=30m max_size=25m;

server {
listen 80;
server_name trigundev.suroot.com www.trigundev.suroot.com
root E:/Server/httpd/html;

location / {
  index index.php index.html;
  autoindex on;
}

location ~ \.php$ {
  #fastcgi_pass 127.0.0.1:9000;
  #fastcgi_index index.php;
  #fastcgi_param  SCRIPT_FILENAME 

E:/Server/httpd/html$fastcgi_script_name;
#fastcgi_cache php;
#fastcgi_cache_valid 5m;

  #proxy_pass http://localhost:8080;
  #proxy_connect_timeout 10;
  #proxy_cache php;
  #proxy_cache_valid 5m;
  #proxy_cache_use_stale error timeout invalid_header;
}

}
}

I’ll try and run this same config through in xp/2000 in a VM later today
and see if it happens there as well.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,1803,1867#msg-1867


#4

Note as well, reason I have two configuration types listed is just to
experiment with various methods for the best Requests/Second for php…
one using a single fast-cgi php-cgi process (which seemed to crash a Lot
when sent a huge amount of request as demonstrated by using ab, although
nginx itself remained stable) the other using proxy_pass for a apache
mod_php only for dynamic content which seemed to be much more stable and
handled the request.

Only when setting the cache directives for either the fastcgi or proxy
method did I incur the immediate crashes.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,1803,1868#msg-1868


#5

Ok Igor,
I ran the same config I posted on win2k just now and it did not crash.
If you think it’s necessary I can try it on xp and vista 32bit versions
as well, although I believe like you suggested it’s probably localized
to x64.

Thanks.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,1803,1872#msg-1872