[BUG] Segmentation Fault (WEBrick)


#1

Hola:
les cuento, cada vez que creo un link o boton dentro de una aplicacion
ror de los manuales que e estado haciendo se me cae el web server y no
tengo la mas minima idea de por que sera.

c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.2.2/lib/active_record/connection_a
dapters/mysql_adapter.rb:197: [BUG] Segmentation fault
ruby 1.8.6 (2007-09-24) [i386-mswin32]

e googleado y no encuentro nada

thx


#2

Asegurate de que tengas instalaga la gema mysql:

gem search mysql

Si no te da resultados, entonces procede a instalarla:

gem install mysql

Saludos.


#3

Ruben Davila wrote:

Asegurate de que tengas instalaga la gema mysql:

gem search mysql

Si no te da resultados, entonces procede a instalarla:

gem install mysql

Saludos.

C:\rails>ruby -v
ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
C:\rails>gem -v
1.3.1
C:\rails>rails -v
Rails 2.2.2

mysql -v = 6.0


#4

Christian R. wrote:

Ruben Davila wrote:

Asegurate de que tengas instalaga la gema mysql:

gem search mysql

Si no te da resultados, entonces procede a instalarla:

gem install mysql

Saludos.

C:\rails>ruby -v
ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
C:\rails>gem -v
1.3.1
C:\rails>rails -v
Rails 2.2.2

mysql -v = 6.0

perdon me equivoque, si tengo instalada todas las gemas necesarias para
levantar aplicaciones RoR, inclullendo “mysql” el problema es que cuando
ejecuto estas aplicaciones en el browser cada ves que accedo a un link o
a un boton el WEBrick se cae.

C:\rails\demo>ruby script\server
=> Booting WEBrick…
=> Rails 2.2.2 application started on http://0.0.0.0:3000
=> Ctrl-C to shutdown server; call with --help for options
[2009-01-12 15:59:45] INFO WEBrick 1.3.1
[2009-01-12 15:59:45] INFO ruby 1.8.6 (2007-09-24) [i386-mswin32]
[2009-01-12 15:59:45] INFO WEBrick::HTTPServer#start: pid=2916
port=3000
127.0.0.1 - - [12/Jan/2009:15:59:47 Hora est. del PacÝfico SA] “GET
/say/goodbye
HTTP/1.1” 200 225

  • -> /say/goodbye
    c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.2.2/lib/active_record/connection_a
    dapters/mysql_adapter.rb:196: [BUG] Segmentation fault
    ruby 1.8.6 (2007-09-24) [i386-mswin32]

This application has requested the Runtime to terminate it in an unusual
way.
Please contact the application’s support team for more information.


#5

Xavier N. wrote:

On Mon, Jan 12, 2009 at 8:32 PM, Christian R.
removed_email_address@domain.invalid wrote:

mysql -v = 6.0

6.0 es una alpha, podria ser que el driver no se entienda con esa.

no entiendo a que te refieres, por mi parte no creo que el problema este
en la base de datos, ya que cuando apreto un boton “guardar” los datos
son guardados en la base de datos como corresponde, el problema es que
el webserver se cae antes de redireccionarme a la pagina siguiente.


#6

2009/1/13 Christian R. removed_email_address@domain.invalid:

en la base de datos, ya que cuando apreto un boton “guardar” los datos
son guardados en la base de datos como corresponde, el problema es que
el webserver se cae antes de redireccionarme a la pagina siguiente.

El sintoma es que el web server se cae, pero la causa es un
segmentation fault que tiene toda la pinta de venir del driver MySQL.
Si a eso le sumamos que el driver es para una version mayor de MySQL
que es menor de la que estas usando… si tuviera que apostarme unas
birras…


#7

On Mon, Jan 12, 2009 at 8:32 PM, Christian R.
removed_email_address@domain.invalid wrote:

mysql -v = 6.0

6.0 es una alpha, podria ser que el driver no se entienda con esa.


#8

Xavier N. wrote:

2009/1/13 Christian R. removed_email_address@domain.invalid:

en la base de datos, ya que cuando apreto un boton “guardar” los datos
son guardados en la base de datos como corresponde, el problema es que
el webserver se cae antes de redireccionarme a la pagina siguiente.

El sintoma es que el web server se cae, pero la causa es un
segmentation fault que tiene toda la pinta de venir del driver MySQL.
Si a eso le sumamos que el driver es para una version mayor de MySQL
que es menor de la que estas usando… si tuviera que apostarme unas
birras…

y como soluciono el problema?


#9

Hola Christian,

Yo estoy teniendo el mismo problema y no encuentro ninguna respuesta.
Vos pudiste solucionarlo finalmente?

Gracias!

Christian R. wrote:

Hola:
les cuento, cada vez que creo un link o boton dentro de una aplicacion
ror de los manuales que e estado haciendo se me cae el web server y no
tengo la mas minima idea de por que sera.

c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.2.2/lib/active_record/connection_a
dapters/mysql_adapter.rb:197: [BUG] Segmentation fault
ruby 1.8.6 (2007-09-24) [i386-mswin32]

e googleado y no encuentro nada

thx


#10

MySQL 6 está en Alpha. Algun motivo para usarlo? No lo puedes meter en
produccion asi que yo dejaria de jugar e instalaria MySQL 5/5.1 que
funciona correctamente con la gema de MySQL.

On 14/01/2009, at 21:03, Christian R.
<removed_email_address@domain.invalid