Bug? installing gems


#1

On Windows, I downloaded ruby-1.8.5-p12-i386-mswin32.zip and unpacked it
to C:\ruby. Then I downloaded rubygems-0.9.2, cd’ed into it and typed
“ruby setup.rb”.

I got :

C:\rubygems-0.9.2>ruby setup.rb
ruby: no such file to load – ubygems (LoadError)

I’m going to try another package/version, but just letting people
know…


#2

On 2/27/07, Mr Magpie removed_email_address@domain.invalid wrote:

know…
You must have RUBYOPT set in the environment, meaning that you have a
different version previously installed.

-austin


#3

Austin Z. wrote:

On 2/27/07, Mr Magpie removed_email_address@domain.invalid wrote:

know…
You must have RUBYOPT set in the environment, meaning that you have a
different version previously installed.

-austin

True, but I renamed the original folder (to hide it) and reinstalled to
the original path, so I wouldn’t expect the old version to be a
problem…


#4

On 2/28/07, Mr Magpie removed_email_address@domain.invalid wrote:

Austin Z. wrote:

On 2/27/07, Mr Magpie removed_email_address@domain.invalid wrote:

know…
You must have RUBYOPT set in the environment, meaning that you have a
different version previously installed.
True, but I renamed the original folder (to hide it) and reinstalled to
the original path, so I wouldn’t expect the old version to be a
problem…

The old version isn’t; your environment is.

-austin