Bug: FXTable: programmatic deselection doesn't work as expected

The next words were posted in the bug tracker of FXRuby, I also made it
here, because I don’t get answer from the administrators.

Hello Lars and company. Was working with FXTable wdiget; what I want to
acomplish is that the the table is read only but full full read only, I
mean: the user can’t select any cell. Well I realized that it is not
possible, so I’ve tried to look for another solutions, and none of them
work for me. The one which put me close to the solution was: “when the
user select a cell, then the robot deselect it”, something like this:

table.connect(SEL_SELECTED) do |sender, selector, data|
table.getItem(data.row, data.col).selected=(false)

Well this is curious, what happen’ when you click a cell?: It becomes
with a ‘SelBackColor’ blue, and it draw inside a kind of ‘stipple’:
following points surrounding the inner cell. What happen when I did the
previous resolution, well the ‘stipple’ is released, but not the blue
‘SelBackColor’. So that’s a partial deselection, it should also release
the blue color…
I’ve tried also:

table.connect(SEL_SELECTED) do |sender, selector, data|
table.handle(table, SEL(SEL_DESELECTED, FXTable::ID_DESELECT_ALL), data)

neither work… hope you can response me, thank you guys.

Was not a bug, judging by the response of Jeroen, maintainer of Fox C++
GUI, is expected to work that way. Nevertheless I did find the solution,
thanks to T. Hemmer:

table.connect(SEL_SELECTED) do |sender, selector, data|

Don’t know how it passed to me -.-!