[BUG] Bus Error OS X

I’m getting the following on OS X (under locomotive) when running the
tests for ferret. Is anybody else getting this error?

rm -f ext/mem_pool.*
rm -f ext/defines.h
** Execute test_units
/Applications/Locomotive/Bundles/rmagickRailsJan2007_x86.locobundle/framework/bin/ruby
-Ilib:test/unit
“/Applications/Locomotive/Bundles/rmagickRailsJan2007_x86.locobundle/framework/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake/rake_test_loader.rb”
“test/unit/tc_document.rb” “test/unit/ts_analysis.rb”
“test/unit/ts_index.rb” “test/unit/ts_query_parser.rb”
“test/unit/ts_search.rb” “test/unit/ts_store.rb” “test/unit/ts_utils.rb”
Loading once
Loaded suite
/Applications/Locomotive/Bundles/rmagickRailsJan2007_x86.locobundle/framework/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake/rake_test_loader
Started
…EEEEEEEE./test/unit/…/unit/analysis/…/…/unit/index/tc_index_reader.rb:539:
[BUG] Bus Error
ruby 1.8.5 (2006-12-25) [i686-darwin8.8.1]

when I try using the acts_as_ferret plugin in my rails application it
crashes with a similar error message.

Will Bailey schrieb:

I’m getting the following on OS X (under locomotive) when running the
tests for ferret. Is anybody else getting this error?

Will,

i get the same error… seems to be macos related … i’m not using
locomotive, but as soon as i
run a test with ferret involved, i get the very same bus error message…

Ben

On 2/26/07, Benjamin K. [email protected] wrote:

Will Bailey schrieb:

I’m getting the following on OS X (under locomotive) when running the
tests for ferret. Is anybody else getting this error?

Will,

i get the same error… seems to be macos related … i’m not using
locomotive, but as soon as i
run a test with ferret involved, i get the very same bus error message…

Hey Ben,

Did you see any errors or warning during the install? I can’t work out
what might be causing this. Did you try running the Ferret unit
tests?

Did you see any errors or warning during the install? I can’t work out

/usr/bin/ld: warning multiple definitions of symbol _setreuid
/opt/local/lib/libruby.dylib(process.o) definition of _setreuid
/usr/lib/gcc/i686-apple-darwin8/4.0.1/…/…/…/libpthread.dylib
(setreuid.So) definition of _setreuid
ruby extconf.rb install ferret
creating Makefile

what might be causing this. Did you try running the Ferret unit
tests?

Loaded suite /opt/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake/
rake_test_loader
Started
…/test/unit/…/unit/analysis/…/…/unit/
index/…/…/unit/query_parser/…/…/unit/search/tc_filter.rb:11:
[BUG] Segmentation fault
ruby 1.8.5 (2006-12-25) [i686-darwin8.8.2]

i’ve testet several other files, most of them crashes… like

test/unit/search/tc_index_searcher.rb:14: [BUG] Segmentation fault
test/unit/search/tc_multi_searcher.rb:72: [BUG] Segmentation fault
test/unit/search/tc_search_and_sort.rb:11: [BUG] Segmentation fault
test/unit/search/tc_spans.rb:13: [BUG] Segmentation fault

each while opening the IndexWriter …

Hope that helps …

Ben

Benjamin K. wrote:

Did you see any errors or warning during the install? I can’t work out

/usr/bin/ld: warning multiple definitions of symbol _setreuid
/opt/local/lib/libruby.dylib(process.o) definition of _setreuid
/usr/lib/gcc/i686-apple-darwin8/4.0.1/…/…/…/libpthread.dylib
(setreuid.So) definition of _setreuid
ruby extconf.rb install ferret
creating Makefile

what might be causing this. Did you try running the Ferret unit
tests?

Loaded suite /opt/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake/
rake_test_loader
Started
…/test/unit/…/unit/analysis/…/…/unit/
index/…/…/unit/query_parser/…/…/unit/search/tc_filter.rb:11:
[BUG] Segmentation fault
ruby 1.8.5 (2006-12-25) [i686-darwin8.8.2]

i’ve testet several other files, most of them crashes… like

test/unit/search/tc_index_searcher.rb:14: [BUG] Segmentation fault
test/unit/search/tc_multi_searcher.rb:72: [BUG] Segmentation fault
test/unit/search/tc_search_and_sort.rb:11: [BUG] Segmentation fault
test/unit/search/tc_spans.rb:13: [BUG] Segmentation fault

each while opening the IndexWriter …

Hope that helps …

Ben

Ben, David,

I switched off of Locomotive to a clean build of ruby/rails

Ruby version 1.8.5 (i686-darwin8.8.2)
RubyGems version 0.9.0
Rails version 1.2.2

I was getting the same errors as Ben on running the tests.

I did get it working by installing version 0.10.1 of ferret.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs