[Bug #1456] invalid $LOAD_PATH when configure with --program-suffix


#1

Bug #1456: invalid $LOAD_PATH when configure with --program-suffix
http://redmine.ruby-lang.org/issues/show/1456

e$B5/I<<Te(B: Kazuhiro NISHIYAMA
e$B%9%F!<%?%9e(B: Open, e$BM%@hEYe(B: Normal
ruby -v: ruby 1.9.2dev (2009-05-10 trunk 23386) [i686-linux]

configuree$B$Ke(B–program-suffix=-trunke$B$r$D$1$F$$$k4D6-$GE:IU%i%$%V%i%j$N%$%s%9%H!<%k@h$He(B$LOAD_PATHe$B$,0lCW$7$F$$$^$;$s!#e(B

% ruby-trunk -run -e 0
ruby-trunk:0:in `require’: no such file to load – un (LoadError)
% ruby-trunk -ve ‘puts $LOAD_PATH’
ruby 1.9.2dev (2009-05-10 trunk 23386) [i686-linux]
/home/kazu/opt/ruby-trunk/lib/ruby/site_ruby/1.9.1
/home/kazu/opt/ruby-trunk/lib/ruby/site_ruby/1.9.1/i686-linux
/home/kazu/opt/ruby-trunk/lib/ruby/site_ruby
/home/kazu/opt/ruby-trunk/lib/ruby/vendor_ruby/1.9.1
/home/kazu/opt/ruby-trunk/lib/ruby/vendor_ruby/1.9.1/i686-linux
/home/kazu/opt/ruby-trunk/lib/ruby/vendor_ruby
/home/kazu/opt/ruby-trunk/lib/ruby/1.9.1
/home/kazu/opt/ruby-trunk/lib/ruby/1.9.1/i686-linux
.
% \ls ~/opt/ruby-trunk/lib/ruby*/
/home/kazu/opt/ruby-trunk/lib/ruby-trunk/:
1.9.1

/home/kazu/opt/ruby-trunk/lib/ruby/:
gems site_ruby vendor_ruby
%


#2

e$B%A%1%C%He(B #1456 e$B$,99?7$5$l$^$7$?!#e(B (by Nobuyoshi N.)

e$B%9%F!<%?%9e(B Opene$B$+$ie(BClosede$B$KJQ99e(B
e$B?JD=e(B % 0e$B$+$ie(B100e$B$KJQ99e(B

Applied in changeset r23390.

http://redmine.ruby-lang.org/issues/show/1456