BrowserCMS demo project creation problem

I hope this is the place to post this. If it’s the Rails list, let me
know.

Running Kubuntu 12.10, rvm 1.18.5, and ruby 1.9.3p374 (2013-01-15
revision 38858) [i686-linux] -

I’ve installed the BrowserCMS gem. It has a command for creation of a
demo CMS " Suitable for learning BrowserCMS" -
browsercms demo [NAME]
Issuing that, all goes well until the end, at which point I get an error
msg:

rake cms:install:migrations
rake aborted!
Could not find a JavaScript runtime. See
https://github.com/sstephenson/execjs for a list of available runtimes
That link advises installation of the execjs gem. Done.

Reissuing the demo creation demand, I have the exact same problem. I
reload rvm (grasping at straws, here), and retry. Same result.

My terminal output for the last try is here: http://pastie.org/6033592

I don’t know what’s happening or what to do about it. I’d appreciate any
help offered!

[posted from ruby-forum.com]

I use node.js it is extremely easy to install and worked for me on two
diff
machines: ubuntu 12.10 . I also hear node.js scales well.

Colby

Thank you. You solved the problem, which was that I had NO idea that
installing the execjs gem was an insufficient response. Have never
worked with js, and it didn’t occur to me that an executable was needed.
Your response quietly implied that, I Googled for how to install such,
did it, and now I’m up and running. Much appreciated!

I am a noob just getting into rails and spent several hours trying to
get
my environment set up last week… so glad I could help. :slight_smile:

Looking into it a bit more, it appears that if you DID want to use
execjs
you would also have to get “therubyracer” gem and run bundle install
after… I’ve heard good things about nodejs though so that’s what I’m
sticking with.

Good luck!