Broken gnuplot

Hi all guys,

lately I have experienced some problems with showing scope and fft plot.
Namely, the plots looks raw and ugly. Once there was an report that
gnuplot
was killed.

Any idea how to check and repair this?

Best,

On 02/25/2014 12:49 PM, Nemanja S. wrote:

Hi all guys,

lately I have experienced some problems with showing scope and fft plot.
Namely, the plots looks raw and ugly. Once there was an report that
gnuplot was killed.

Any idea how to check and repair this?

Are you using gnuplot?

What exactly are doing and which tools are you using?

M


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

Is there any way to repair this, because one or two months ago,
everything
was ok? Or, is there any log where I can figure what is the exact
problem?

On Tue, Feb 25, 2014 at 8:07 AM, Nemanja S. [email protected]
wrote:

So, it is default installation. I use RHEL6. Some time ago I uninstalled
numpy due to installation of new version of matplotlib (I don’t know if
this is important).
Now my gui looks like this

That’s using wxPython, not gnuplot. It doesn’t use matplotlib, either
(which depends on numpy, so if you installed matplotlib, you also still
have numpy). That will have no effect on the wxgui plots.

This is possibly related to opengl, though. You can turn that off by
editing $prefix/etc/gnuradio/conf.d/gr-wxgui.conf.

Tom

Thank you Tom. I try tomorrow.

On Tue, Feb 25, 2014 at 9:35 AM, Nemanja S. [email protected]
wrote:

Is there any way to repair this, because one or two months ago, everything
was ok? Or, is there any log where I can figure what is the exact problem?

Well, since we don’t know what you changed on your side, it’s hard to
help you fix it. Again, numpy, matplotlib, and gnuplot have nothing to
do with this.

Have you tried my suggestion of turning opengl off? That tends to be
the main problem people have with using wxgui.

Tom

On Wed, Feb 26, 2014 at 6:23 AM, Nemanja S. [email protected]
wrote:

RuntimeError: Unable to import OpenGL. Are Python wrappers for OpenGL
installed?

Ok, so definitely stick with the non-OpenGL version.

As to why it’s stopped working for you, I can’t say. Can you roll back
to an older version of GNU Radio that you know was working to see if
it’s something there? If not, it’s something with your system, and we
can’t really be much help with that.

Tom

When I use nongl option, then the gui looks like on the figure I posted,
and when I use gl option, the follosing error occures:
Traceback (most recent call last):
File “/home/savi_ne/work/gnuradio/GRC/top_block.py”, line 14, in

from gnuradio.wxgui import fftsink2
File
“/usr/local/lib64/python2.6/site-packages/gnuradio/wxgui/fftsink2.py”,
line
34, in
raise RuntimeError(“Unable to import OpenGL. Are Python wrappers
for
OpenGL installed?”)
RuntimeError: Unable to import OpenGL. Are Python wrappers for OpenGL
installed?

Hi all again,

actually yes, the problem was due to numpy. Namely, I uninstalled 1.4.1
which I have on my RHEL6 and installed 1.5 or something. During that
opengl
was somehow deleted and when I installed using package manager, numpy
1.4.1
was installed again.

best

If somebody have the same problem, just install pyopengl from source.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs