Bootstrap error in gnu trunk


#1

I am using the cygwin environment.
As my college doesn’t allow the svn command to download the latest
gnuradio
trunk, giving the error ‘cannot resolve hostname’, so I used the windows
based software ‘TortoiseSVN’ and downloaded everything in the folder
‘gnuradio’.

Does the svn within cygwin perform the same function as what the
software
‘tortoisesvn’ did for me?

I read the svn+lineseparator issue on the page ---------------and
applied
the proposed fix but it gave the same error as posted below.

Anyhow I copied this ‘gnuradio’ folder to c:\cygwin\usr\src, so using
the
bash i entered the command

./bootstrap

I got the following error.

./bootstrap: line 2: $’\r’: command not found
./bootstrap: line 21: $’\r’: command not found
./bootstrap: line 22: $’\r’: command not found
./bootstrap: line 24: $’\r’: command not found
‘: No such file or directorydirectory config ./bootstrap: line 26: $'autoconf\r': command not found ./bootstrap: line 27: $'autoheader\r': command not found 'ibtoolize: unrecognized option–automake
libtoolize: Try libtoolize --help' for more information. 'utomake-1.10: unknown warning categorynone
configure.ac: no proper invocation of AM_INIT_AUTOMAKE was found.
configure.ac: You should verify that configure.ac invokes
AM_INIT_AUTOMAKE,
configure.ac: that aclocal.m4 is present in the top-level directory,
configure.ac: and that aclocal.m4 was recently regenerated (using
aclocal).
configure.ac:84: installing ./install-sh' ./bootstrap: line 31: $'\r': command not found ./bootstrap: line 33: syntax error near unexpected token$’\r’’
'/bootstrap: line 33: `(cd usrp2/firmware ; ./bootstrap)

Can anybody figure out the error?
Some general information:
I am using automake versions 1.4, 1.5, 1.6, 1.7, 1.8, 1.9, 1.10 all
selected
when using setup.exe to install cygwin

Waiting for help. I must use GRC for my project.


#2

Sorry I skipped the link.

I read the svn+lineseparator issue on the page
http://gnuradio.org/trac/wiki/WindowsTips

On 10/9/08, Umair N. removed_email_address@domain.invalid wrote:

the proposed fix but it gave the same error as posted below.

configure.ac: no proper invocation of AM_INIT_AUTOMAKE was found.
Some general information:


Umair


#3

I am using the cygwin environment.
As my college doesn’t allow the svn command to download the latest
gnuradio
trunk, giving the error ‘cannot resolve hostname’, so I used the windows
based software ‘TortoiseSVN’ and downloaded everything in the folder
‘gnuradio’.

Does the svn within cygwin perform the same function as what the software
‘tortoisesvn’ did for me?

Yes, except that it doesn’t add an extra character to every line.

libtoolize: Try libtoolize --help' for more information. '/bootstrap: line 33:(cd usrp2/firmware ; ./bootstrap)

Can anybody figure out the error?

Perhaps you should look at bootstrap and see if it looks like normal
text.
Compare it to something like configure.ac.

My guess is that you will need to run dos2unix on bootstrap, and
possibly on
other files not mentioned in the WindowsTips wiki page.

– Don W.


#4

The dos2unix command is there in WindowsTips wiki page and I tried it as
i
mentioned in my first post. Still I get the same error the one I
mentioned
previously. Using the dos2unix doesn’t seem to be doing what it should
be
doing.
Anyother option?

Perhaps you should look at bootstrap and see if it looks like normal
text.