Bootstrap 3.1.1 is showing as BS 2

I should first mention that I’m new to rails, but I updated to Ubuntu 14
today and I cloned my latest project from Github after installation.
Everything seems to be working just as my last push, however my project
is
styled with Bootstrap 2… but it should be 3.1.1.

I am not using the direct files in the stylesheets folder, instead I
created my own custom.css.scss and did @import “boostrap”;. I also
included the these in my application.js file.

//= require jquery//= require jquery_ujs//= require bootstrap//=
require_tree .

my gemfile has:

source 'https://rubygems.org’gem ‘rails’, '3.2.16’gem
'bootstrap-sass’gem
‘sass-rails’, '3.2.5’gem 'bootstrap’gem ‘bcrypt-ruby’, '3.0.1’gem
‘faker’,
'1.0.1’gem ‘will_paginate’, '3.0.3’gem 'bootstrap-will_paginate’gem
‘jquery-rails’, '2.0.2’group :development, :test do gem ‘sqlite3’,
‘1.3.5’ gem ‘rspec-rails’ gem ‘pry-rails’ gem 'pry-theme’end# Gems
used
only for assets and not required# in production environments by
default.group :assets do gem ‘coffee-rails’, ‘3.2.2’ gem ‘uglifier’,
'1.2.3’endgroup :test do gem ‘capybara’ gem ‘factory_girl_rails’,
‘4.1.0’ gem ‘cucumber-rails’, ‘1.2.1’, :require => false gem
‘database_cleaner’, ‘0.7.0’ # gem ‘launchy’, ‘2.1.0’ # gem
‘rb-fsevent’,
‘0.9.1’, :require => false # gem ‘growl’, '1.0.3’endgroup :production
do
gem ‘pg’, '0.12.2’end

Any ideas on what might be causing this?..

Thanks in advance for any feedback you may have!

You should specify the gem version in your Gemfile.

gem ‘bootstrap-sass’, ‘~> 3.1.1.1’

Why are you using the ‘bootstrap’ and ‘bootstrap-sass’ gem?

Em segunda-feira, 28 de abril de 2014 22h44min10s UTC-3, Colin S.
escreveu:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs