Booting WEBrick ... server:invalid option: --trace?


#1

I’m migrating an old Rails App to a new server, I think I’ve got most
of my issues worked out so far. But…

When I run script/server --trace in the app I get the following
output… and I have no clue what to do or even where to look… Any
guidance or assistance would be greatly appreciated.

script/server --trace
=> Booting WEBrick…
server: invalid option: --trace

Thanks in advance for any guidance/assistance.

rusty


#2

script/server --help
Usage: server [options]
-p, --port=port Runs Rails on the specified port.
Default: 3000
-b, --binding=ip Binds Rails to the specified ip.
Default: 0.0.0.0
-c, --config=file Use custom rackup configuration
file
-d, --daemon Make server run as a Daemon.
-u, --debugger Enable ruby-debugging for the
server.
-e, --environment=name Specifies the environment to run
this server under (test/development/production).
Default: development
-P, --path=/path Runs Rails app mounted at a
specific path.
Default: /

-h, --help                       Show this help message.

I don’t see --trace in there anywhere.


#3

yup, definitely not there… doh.

ok, so I ran script/server without the trace and I get this

=> Booting WEBrick…

and then it comes back to the command prompt. It doesn’t start the
app…? I was trying to use trace to see why.

Is there any way to troubleshoot this?