Blank page output :(


#1

Hello all,

I’ve been struggling with apache/fastcgi to get SimpleTicket to run with
it.
At the moment it looks to me as if it’s running.

I’m using Mac OS 10.4.5
Apache that comes with OSX client (apache 1).
I did a gem update.
And installed fastcgi as instructed in:
http://wiki.rubyonrails.com/rails/pages/FastCGI+on+OS+X

If I open a browser and go to the url of the rails app,
I see the request in the development.log and it says it renders and
returns status 200.
But the output in the browser is a blank page…
I tried deleting the sessions, which I read somewhere on the
mailinglist, but that didn’t help.
The first line in the development.log states that the environment.rb
file used by SimpleTicket
uses the old environment.rb syntax. Could this be the problem??

development.log:

Your environment.rb uses the old syntax, it may not continue to work in
future releases.
For upgrade instructions please see:
http://manuals.rubyonrails.com/read/book/19

Processing TicketsController#index (for 82.168.159.24 at 2006-04-24
14:26:05) [GET]
Session ID: d55cf422bb16714c754a503aa82ea334
Parameters: {“action”=>“index”, “controller”=>“tt/tickets”}
GOT HERE
Rendering tt/tickets/index
Completed in 0.00432 (231 reqs/sec) | Rendering: 0.00205 (47%) | 200 OK
[http://tickets.maconline.nl/]

I hope this is a stupid simple mistake, due to me being new to fastcgi
:slight_smile:
I had it working with cgi, but I wanted to try out fastcgi.
So I can always go back, if I can’t find a solution.

Thanks in advance!
Kind regards,
Eloy.