BladRF

I am working on bladeRF, dose anyone working on it and facing this
error?
Ubuntu 13.04
linux; GNU C++ version 4.7.3; Boost_105300;
UHD_003.005.004-140-gfb32ed16

<<< Welcome to GNU Radio Companion 3.7.1 >>>

i got this error while running osmocom_fft.

[email protected]:~/gnuradio/gr-osmosdr$ osmocom_fft -a
bladerf=0,fpga=/opt/bladeRF/fpga/hostedx115.rbf -s 8000000 -f 446000000
linux; GNU C++ version 4.7.3; Boost_105300;
UHD_003.005.004-140-gfb32ed16

gr-osmosdr v0.1.0-23-g6f4e16ff (0.1.1git) gnuradio 3.7.1
built-in source types: file fcd rtl rtl_tcp uhd hackrf

FATAL: Failed to open HackRF device (-5) HACKRF_ERROR_NOT_FOUND

Trying to fill up 1 missing channel(s) with null source(s).
This is being done to prevent the application from crashing
due to a gnuradio bug. The maintainers have been informed.

Source has no sample rates (wrong device arguments?).

BLADERF CLI info
////////////////////////////////////////////////////////////////////////////////////////
bladeRF> load fpga /opt/bladeRF/fpga/hostedx115.rbf
Loading fpga from /opt/bladeRF/fpga/hostedx115.rbf…
Done.
bladeRF> info

Serial #: 5cc7c3a07c529478308a9d5424965eb0
VCTCXO DAC calibration: 0x99d1
FPGA size: 115 KLE
FPGA loaded: yes
USB bus: 3
USB address: 2
Backend: libusb
Instance: 0

bladeRF> version

bladeRF-cli version: 0.5.0-git-130cbba
libbladeRF version: 0.6.2-git-130cbba

Firmware version: 1.5.3-git-
FPGA version:

GR-OSMOCOM enabled components


– ######################################################
– # gr-osmosdr enabled components
– ######################################################
– * Python support
– * Osmocom IQ Imbalance Correction
– * FUNcube Dongle
– * IQ File Source
– * Osmocom RTLSDR
– * RTLSDR TCP Client
– * Ettus USRP Devices
– * HackRF Jawbreaker
– * nuand bladeRF

– ######################################################
– # gr-osmosdr disabled components
– ######################################################
– * sysmocom OsmoSDR
– * FUNcube Dongle Pro+
– * Osmocom MiriSDR

– Building for version: v0.1.0-23-g6f4e16ff / 0.1.1git
– Using install prefix: /opt/gnuradio-3.7.1git
– Configuring done
– Generating done
– Build files have been written to: /home/junaid/gnuradio/gr-osmosdr

Regards
Muhammad Junaid

Yes, I had this problem. As far as I remember I uninstalled bladerf and
gr-osmosdr, then manually deleted all remains of it and of hackrf (what
I
never used) from my system, compiled and installed again bladerf,
compiled a
fresh version of gr-osmosdr with the cmake-option not to build hackrf
support, installed it, finally everything worked.

Ralph.

From: [email protected]lid
[mailto:[email protected]lid] On Behalf Of
Muhammad JUNAID
Sent: Tuesday, October 22, 2013 3:02 PM
To: [email protected]
Cc: [email protected]
Subject: [Discuss-gnuradio] BladRF

I am working on bladeRF, dose anyone working on it and facing this
error?

Ubuntu 13.04

linux; GNU C++ version 4.7.3; Boost_105300;
UHD_003.005.004-140-gfb32ed16

<<< Welcome to GNU Radio Companion 3.7.1 >>>

i got this error while running osmocom_fft.

[email protected]:~/gnuradio/gr-osmosdr$ osmocom_fft -a
bladerf=0,fpga=/opt/bladeRF/fpga/hostedx115.rbf -s 8000000 -f 446000000

linux; GNU C++ version 4.7.3; Boost_105300;
UHD_003.005.004-140-gfb32ed16

gr-osmosdr v0.1.0-23-g6f4e16ff (0.1.1git) gnuradio 3.7.1

built-in source types: file fcd rtl rtl_tcp uhd hackrf

FATAL: Failed to open HackRF device (-5) HACKRF_ERROR_NOT_FOUND

Trying to fill up 1 missing channel(s) with null source(s).

This is being done to prevent the application from crashing

due to a gnuradio bug. The maintainers have been informed.

Source has no sample rates (wrong device arguments?).

BLADERF CLI info

////////////////////////////////////////////////////////////////////////////
////////////

bladeRF> load fpga /opt/bladeRF/fpga/hostedx115.rbf

Loading fpga from /opt/bladeRF/fpga/hostedx115.rbf…

Done.

bladeRF> info

Serial #: 5cc7c3a07c529478308a9d5424965eb0

VCTCXO DAC calibration: 0x99d1

FPGA size: 115 KLE

FPGA loaded: yes

USB bus: 3

USB address: 2

Backend: libusb

Instance: 0

bladeRF> version

bladeRF-cli version: 0.5.0-git-130cbba

libbladeRF version: 0.6.2-git-130cbba

Firmware version: 1.5.3-git-

FPGA version:

GR-OSMOCOM enabled components

– ######################################################

– # gr-osmosdr enabled components

– ######################################################

– * Python support

– * Osmocom IQ Imbalance Correction

– * FUNcube Dongle

– * IQ File Source

– * Osmocom RTLSDR

– * RTLSDR TCP Client

– * Ettus USRP Devices

– * HackRF Jawbreaker

– * nuand bladeRF

– ######################################################

– # gr-osmosdr disabled components

– ######################################################

– * sysmocom OsmoSDR

– * FUNcube Dongle Pro+

– * Osmocom MiriSDR

– Building for version: v0.1.0-23-g6f4e16ff / 0.1.1git

– Using install prefix: /opt/gnuradio-3.7.1git

– Configuring done

– Generating done

– Build files have been written to: /home/junaid/gnuradio/gr-osmosdr

Regards

Muhammad Junaid

I am using Kubuntu 12.04 LTS 32bit, boost should be something like 1.49
or
1.50, gnuradio is latest build 3.7, and gr-osmosdr a few weeks old as
with
the latest version gqrx and bladerf do not work together. For exact
versions
you have to wait a bit, I do not have this system at hand right now :slight_smile:

Ralph.

From: Muhammad JUNAID [mailto:[email protected]]
Sent: Wednesday, October 23, 2013 11:51 AM
To: Ralph A. Schmid, dk5ras
Subject: Re: [Discuss-gnuradio] BladRF

Dear Ralph,

What is Ubuntu ,GNURadio, Osmosdr and Boost version on your successful
installation of BladRF.

Regards

Muhammad Junaid

On Wednesday, October 23, 2013 2:23 PM, “Ralph A. Schmid, dk5ras”
[email protected] wrote:

Yes, I had this problem. As far as I remember I uninstalled bladerf and
gr-osmosdr, then manually deleted all remains of it and of hackrf (what
I
never used) from my system, compiled and installed again bladerf,
compiled a
fresh version of gr-osmosdr with the cmake-option not to build hackrf
support, installed it, finally everything worked.

Ralph.

From: [email protected]lid
[mailto:[email protected]lid] On Behalf Of
Muhammad JUNAID
Sent: Tuesday, October 22, 2013 3:02 PM
To: [email protected]
Cc: [email protected]
Subject: [Discuss-gnuradio] BladRF

I am working on bladeRF, dose anyone working on it and facing this
error?

Ubuntu 13.04

linux; GNU C++ version 4.7.3; Boost_105300;
UHD_003.005.004-140-gfb32ed16

<<< Welcome to GNU Radio Companion 3.7.1 >>>

i got this error while running osmocom_fft.

[email protected]:~/gnuradio/gr-osmosdr$ osmocom_fft -a
bladerf=0,fpga=/opt/bladeRF/fpga/hostedx115.rbf -s 8000000 -f 446000000

linux; GNU C++ version 4.7.3; Boost_105300;
UHD_003.005.004-140-gfb32ed16

gr-osmosdr v0.1.0-23-g6f4e16ff (0.1.1git) gnuradio 3.7.1

built-in source types: file fcd rtl rtl_tcp uhd hackrf

FATAL: Failed to open HackRF device (-5) HACKRF_ERROR_NOT_FOUND

Trying to fill up 1 missing channel(s) with null source(s).

This is being done to prevent the application from crashing

due to a gnuradio bug. The maintainers have been informed.

Source has no sample rates (wrong device arguments?).

BLADERF CLI info

////////////////////////////////////////////////////////////////////////////
////////////

bladeRF> load fpga /opt/bladeRF/fpga/hostedx115.rbf

Loading fpga from /opt/bladeRF/fpga/hostedx115.rbf…

Done.

bladeRF> info

Serial #: 5cc7c3a07c529478308a9d5424965eb0

VCTCXO DAC calibration: 0x99d1

FPGA size: 115 KLE

FPGA loaded: yes

USB bus: 3

USB address: 2

Backend: libusb

Instance: 0

bladeRF> version

bladeRF-cli version: 0.5.0-git-130cbba

libbladeRF version: 0.6.2-git-130cbba

Firmware version: 1.5.3-git-

FPGA version:

GR-OSMOCOM enabled components

– ######################################################

– # gr-osmosdr enabled components

– ######################################################

– * Python support

– * Osmocom IQ Imbalance Correction

– * FUNcube Dongle

– * IQ File Source

– * Osmocom RTLSDR

– * RTLSDR TCP Client

– * Ettus USRP Devices

– * HackRF Jawbreaker

– * nuand bladeRF

– ######################################################

– # gr-osmosdr disabled components

– ######################################################

– * sysmocom OsmoSDR

– * FUNcube Dongle Pro+

– * Osmocom MiriSDR

– Building for version: v0.1.0-23-g6f4e16ff / 0.1.1git

– Using install prefix: /opt/gnuradio-3.7.1git

– Configuring done

– Generating done

– Build files have been written to: /home/junaid/gnuradio/gr-osmosdr

Regards

Muhammad Junaid

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs