": bind() to 0.0.0.0:80" and relation between 'logs' directory and 'pid' direction

Hello,

I had compiled my Nginx using ‘.configure’, ‘make’ and ‘make install’
commands.

nginx.pid file occurs on ‘logs’ directory as default. If I change set
‘pid’
directive (e.g. pid sbin/nginx.pid) on my nginx.conf file then I cannot
restart Nginx and I get following message at second restart service.

[emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)

And if I change the direction as ‘pid logs/nginx.pid’ everything is
perfect!

Would it be possible to change Nginx default settings?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,259208,259208#msg-259208

I’ve found the reason. My init script that is found on
/etc/init.d/nginx.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,259208,259211#msg-259211

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs