Binarylogic-searchlogic ~> 2.0 binarylogic-authlogic mbleigh-subdomain_fu

I am having problem starting my app, here’s the error message, i am
running Ubuntu 9.04 with Apache with Passenger:

The application has exited during startup (i.e. during the evaluation
of config/environment.rb). The error message can be found below. To
solve this problem, please follow any instructions in the error
message.
Error message:
Missing these required gems: binarylogic-searchlogic ~> 2.0
binarylogic-authlogic mbleigh-subdomain_fu You’re running: ruby
1.9.1.0 at /usr/local/bin/ruby rubygems 1.3.5 at /usr/local/lib/ruby/
gems/1.9.1 Run rake gems:install to install the missing gems.

This is my environment.rb:

config.gem ‘binarylogic-searchlogic’, :lib => ‘searchlogic’, :source
=> ‘http://gems.github.com’, :version => ‘~> 2.0’
#config.gem ‘mislav-will_paginate’, :lib => ‘will_paginate’, :source
=> ‘http://gems.github.com
config.gem ‘RedCloth’, :lib => ‘redcloth’
config.gem ‘hpricot’, :source => ‘http://code.whytheluckystiff.net
config.gem ‘binarylogic-authlogic’, :lib => ‘authlogic’, :source =>
http://gems.github.com
config.gem ‘mbleigh-subdomain-fu’, :source => “http://
gems.github.com”, :lib => “subdomain-fu”

I did “gem install authlogic”, it is installed but I still get the
same message telling me binarylogic-authlogic missing.

Tried to run “rake gems:install”, and this is what I get:

(in /var/www/project/005)
rake aborted!
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:31: syntax error, unexpected ‘:’, expecting
keyword_then or ‘,’ or ‘;’ or ‘\n’
when “string”, “text”: “‘foo’”
^
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:32: syntax error, unexpected keyword_when,
expecting keyword_end
when “integer”: 1
^
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:32: syntax error, unexpected ‘:’, expecting
keyword_end
when “integer”: 1
^
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:33: syntax error, unexpected ‘:’, expecting
keyword_end
when “float”: 1.0
^
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:34: syntax error, unexpected ‘:’, expecting
keyword_end
when “date”: “’#{Date.today}’”
^
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:35: syntax error, unexpected keyword_when,
expecting keyword_end
when “datetime”, “time”, “timestamp”: “’#{Time.now}’”
^
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:35: syntax error, unexpected ‘,’, expecting
keyword_end
when “datetime”, “time”, “timestamp”: “’#{Time.now}’”
^
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:35: syntax error, unexpected ‘,’, expecting
keyword_end
when “datetime”, “time”, “timestamp”: “’#{Time.now}’”
^
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:35: syntax error, unexpected ‘:’, expecting
keyword_end
when “datetime”, “time”, “timestamp”: “’#{Time.now}’”
^
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:36: syntax error, unexpected keyword_when,
expecting keyword_end
when “boolean”: false
^
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:36: syntax error, unexpected ‘:’, expecting
keyword_end
when “boolean”: false
^
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:37: syntax error, unexpected ‘:’, expecting
keyword_end
when “binary”: “’’”
^
/var/www/project/005/vendor/plugins/sweatshop/tasks/
sweatshop_tasks.rake:70: syntax error, unexpected keyword_end,
expecting $end
/var/www/project/005/Rakefile:9:in `require’
(See full trace by running task with --trace)

Deeply appreciate any help.

Regards

Johnny

Remove the “binarylogic-” part from your environment.rb file. (Do this
for the other gems such as “mislav”, “mbleigh”, etc.)

These gems are hosted on gems.rubyforge.org (gemcutter.org) now and
don’t require the author prefix.

Eric

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs