'bignum too big to convert into long' while migration in rails

While i run rake db:migrate i got below error ,let me know any one .
Please it is urgent to me.

D:\raj\tweasier>rake db:migrate --trace
(in D:/raj/tweasier)
DEPRECATION WARNING: Rake tasks in
vendor/plugins/open_flash_chart_2/tasks, vend
or/plugins/resque/tasks, and vendor/plugins/resque/tasks are deprecated.
Use lib
/tasks instead. (called from
c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/t
asks/rails.rb:10)
RESQUE CONF {“production_private”=>“localhost:9878”,
“auth”=>{“username”=>“tweas
ier”, “password”=>“cdzvc4”}, “development”=>“localhost:6382”,
“test”=>“localhost
:6379”, “staging”=>“localhost:6379”}
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
bignum too big to convert into long' c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/requirement.rb:109:inhash’
c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/requirement.rb:109:in hash' c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/specification.rb:695:inhash’
c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in
inject' c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/specification.rb:694:ineach’
c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/specification.rb:694:in
inject' c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/specification.rb:694:inhash’
c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/locator.rb:81:in
plugins' c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:ininject’
c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/locator.rb:81:in
each' c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/locator.rb:81:ininject’
c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/locator.rb:81:in
plugins' c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/loader.rb:109:inlocate_plugins’
c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/loader.rb:108:in
map' c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/loader.rb:108:inlocate_plugins’
c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/loader.rb:32:in
all_plugins' c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/loader.rb:22:in
plugins’
c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/plugin/loader.rb:53:in
add_plugin_load_paths' c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:294:inadd_plu
gin_load_paths’
c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:136:in
process ' c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:113:insend’
c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:113:in
run' D:/raj/tweasier/config/environment.rb:4 c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:ingem_original
_require’
c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in
require' c:/Ruby186/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/depende ncies.rb:156:inrequire’
c:/Ruby186/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/depende
ncies.rb:521:in new_constants_in' c:/Ruby186/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/depende ncies.rb:156:inrequire’
c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/tasks/misc.rake:4
c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in call' c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:inexecute’
c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in each' c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:inexecute’
c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in
invoke_with_cal l_chain' c:/Ruby186/lib/ruby/1.8/monitor.rb:242:insynchronize’
c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in
invoke_with_cal l_chain' c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:ininvoke_prerequi
sites’
c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in each' c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:ininvoke_prerequi
sites’
c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in
invoke_with_cal l_chain' c:/Ruby186/lib/ruby/1.8/monitor.rb:242:insynchronize’
c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in
invoke_with_cal l_chain' c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:ininvoke’
c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in
invoke_task' c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:intop_level’
c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in each' c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:intop_level’
c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in
standard_excep tion_handling' c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:intop_level’
c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in run' c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:instandard_excep
tion_handling’
c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in run' c:/Ruby186/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31 c:/Ruby186/bin/rake:19:inload’
c:/Ruby186/bin/rake:19

On Tuesday, April 26, 2011 11:36:10 PM UTC-6, Ruby-Forum.com User wrote:

/tasks instead. (called from
c:/Ruby186/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/t
asks/rails.rb:10)

Well, it appears you’re on windows using ruby 1.8.6 with rails 2.3.8
(and
apparently have at least two plugins: one named open_flash_chart_2 and
resque)…

RESQUE CONF {“production_private”=>“localhost:9878”,
“auth”=>{*****}, “development”=>“localhost:6382”,“test”=>“localhost
:6379”, “staging”=>“localhost:6379”}

Yeah, you really ought to make a habit of scrubbing things like username
and
passwords out of any data you copy/paste into a post. Perhaps they’re
throw-away, dev. machine-only credentials. Even if they are, good
security
habits will protect you…

** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
bignum too big to convert into `long’

I certainly hope you Google’d: “bignum too big to convert into long”
first.
I’ll assume you did and looked at the results (that aren’t your own
post).
If your then actually look at the top of your stack trace (which it’s
awesome you provided):

c:/Ruby186/lib/ruby/site_ruby/1.8/rubygems/requirement.rb:109:in `hash’

The innermost scope is clearly within the “requirement.rb” file (line
109)
of rubygems itself. So, add “rubygems” to your error phrase in
Google…
Anyhow, that’s what I did. I immediately found some posts that, though
people had a slightly different setup/problem/environment, they all
seemed
to point to the problem being a bug in old versions of rubygems.

What version of rubygems are you using? I’m guessing its the version
bundled
with the 1.8.6 windows installer which I’m guessing is 1.3.7? If I’m
right
then this is an old version so perhaps you need to upgrade your
version up
rubygems? If this is the case, you’ll also need to upgrade to a newer
version of ruby because rubygems 1.3.7 is the newest version that
supports
ruby 1.8.6.

So, I’m my guess (it is just a guess) is correct, you really ought to
attempt to install ruby 1.8.7 (which should come with the latest
rubygems)
and use it to run your rake task.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs