Benchmark_rx is not receiving any packet for 8PSK modulation

Hello,

I am working on the effect of adaptive modulation in packet loss. I am
running my codes in USRP2 with XCVR2450 daughter-board and I am using
UHD_003_001_002 image. I am using benchmark_tx and benchmark_rx codes in
the
gnuradio-examples/python/digital folder to find packet loss for
different
modulation schemes.

Now, when I run my the benchmark codes with dbpsk and dqpsk modulation,
the
receiver receives packets. However, when I run the codes with d8psk
modulation scheme, the receiver just sits idle waiting for the packets
but
does not receive anything. Let’s say I am giving the following commands
in
the benchmark programs:

./benchmark_tx.py -f 2.4G -r 1M -e eth2 -m d8psk --tx-ampl 0.95 (I am
using
a very high transmitter power)

./benchmark_rx.py -f 2.4G -r 1M -e eth2 -m d8psk

I am getting the following packet reception ratios for different
modulation
schemes:

dbpsk: 99% dqpsk: 92% d8psk: 0% !!

I expected to get less packets (higher packet loss) through d8psk
modulation
since it is transmitting at a higher data rate. But the receiver is not
receiving anything at all !! Does it mean that the channel between the
transmitter and the receiver is simply not good enough to transmit 3 bit
per
second per Hz? In other words, am I exceeding Shannon’s capacity here?

Thanks,

Nazmul


Muhammad Nazmul I.

Graduate Student
Electrical & Computer Engineering
Wireless Information & Networking Laboratory
Rutgers, USA.

I have similar problem. My stats look on par with yours for dbpsk and
dqpsk.

I have a USRP1, Flex900, DBS-RX and using
./benchmark_tx.py -f 900e6 -m d8psk --tx-gain 3000 (<-- diff from ampl
.95)
I get high BER output at the Rx side.
The Rx side detects numerous packets, but none of which are correct.

Jerry

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs