Bad file descriptor error using Net::HTTP


#1

I am trying to access a .net page via my ruby app and pass it a couple
parameters. Every thing I have tried has resulted in this Bad file
descriptor, I am wondering if it is something wrong with my
configuration, not the code. Here is the code that is causing
problems:

Net::HTTP.version_1_2
Net::HTTP.start(‘www.url.com’, 80) {
|http|
response =
http.post(’/DoSomething.aspx’,
‘id=#{params[:id]}&path=#{params[:imagerecord]}’,
{ ‘Content-Type’ => ‘application/x-www-form-
urlencoded’ })
puts response.body()
}

Here is the error I get:

Errno::EBADF (Bad file descriptor - connect(2)):
c:/ruby/lib/ruby/1.8/net/http.rb:560:in initialize' c:/ruby/lib/ruby/1.8/net/http.rb:560:inconnect’
c:/ruby/lib/ruby/1.8/timeout.rb:48:in timeout' c:/ruby/lib/ruby/1.8/timeout.rb:76:intimeout’
c:/ruby/lib/ruby/1.8/net/http.rb:560:in connect' c:/ruby/lib/ruby/1.8/net/http.rb:553:indo_start’
c:/ruby/lib/ruby/1.8/net/http.rb:542:in start' c:/ruby/lib/ruby/1.8/net/http.rb:440:instart’

I am on Windows 2003 serer with Ruby 1.8.4 and Mongrel. Any help would
be greatly appreciated.


#2

On Jun 28, 8:20 am, removed_email_address@domain.invalid wrote:

    http.post('/DoSomething.aspx',
c:/ruby/lib/ruby/1.8/net/http.rb:560:in `connect'
c:/ruby/lib/ruby/1.8/timeout.rb:48:in `timeout'
c:/ruby/lib/ruby/1.8/timeout.rb:76:in `timeout'
c:/ruby/lib/ruby/1.8/net/http.rb:560:in `connect'
c:/ruby/lib/ruby/1.8/net/http.rb:553:in `do_start'
c:/ruby/lib/ruby/1.8/net/http.rb:542:in `start'
c:/ruby/lib/ruby/1.8/net/http.rb:440:in `start'

I am on Windows 2003 serer with Ruby 1.8.4 and Mongrel. Any help would
be greatly appreciated.

Line 560 of net/http.rb is this:

s = timeout(@open_timeout) { TCPSocket.open(conn_address(),
conn_port()) }

What happens when you run this standalone snippet?

require ‘socket’
require ‘timeout’

s = Timeout.timeout(5){
TCPSocket.open(url, 80)
}

p s

s.close

Regards,

Dan


#3

On Jun 28, 10:57 am, Daniel B. removed_email_address@domain.invalid wrote:

Net::HTTP.version_1_2
Here is the error I get:

require ‘socket’

Regards,

Dan

Dan,

Thanks. Here is the error I get when executing the above code:

Timeout::Error (execution expired):
c:/ruby/lib/ruby/1.8/timeout.rb:54:in open' c:/ruby/lib/ruby/1.8/timeout.rb:56:intimeout’

I know it’s a valid URL. The page I am trying to access is sitting on
the same box as my rails app.


#4

On Jun 28, 9:20 am, removed_email_address@domain.invalid wrote:

On Jun 28, 10:57 am, Daniel B. removed_email_address@domain.invalid wrote:

require ‘socket’

c:/ruby/lib/ruby/1.8/timeout.rb:56:in `timeout’

I know it’s a valid URL. The page I am trying to access is sitting on
the same box as my rails app.

That’s peculiar. Firewall or proxy issue perhaps? Maybe you need
rubysspi?

http://rubyforge.org/projects/rubysspi/

Otherwise, I’m at a loss.

Regards,

Dan