[Backport21 - Backport #9636] Fiddle::Importer で Segmentation fault ga

Issue #9636 has been updated by Kiyoteru Inoue.

File testcode.rb added
File log.txt added

Fiddle::Impoter で、 Segmentation fault が発生します。

Ruby 1.8.7-p375
Ruby 1.9.3-p545
Ruby 2.1.1-p76

いずれのバージョンでも、同様のコアダンプを発生させています。
Ruby 2.1.1-p76 で実行時のコアダンプを添付します。

実行環境は
Ubuntu 13.10 x86_64 です。CPU の Byte Order は Little Endian です。

実行したテストコードと、Segmentation fault コアダンプのログを貼っておきます。
いずれのRubyバージョンでも発生するので、ライブラリ側の問題ではないと思うのですが。

使用したライブラリは AquesTalk2(linux評価版)です。
開発版(有償)でも、同様のコアダンプが発生しています。

http://www.a-quest.com/download/index.html

よろしくお願いします。
タイトルは入力ミスしてしまいました。訂正方法がわからないのでこのままです。すみません。


Backport #9636: Fiddle::Importer で Segmentation fault ga
https://bugs.ruby-lang.org/issues/9636#change-45785

  • Author: Kiyoteru Inoue
  • Status: Open
  • Priority: Normal
  • Assignee:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs