BackgroundRB HELP!

Buenas Tardes…
Tengo un problema luego de actualizar BackgroundRB, la situacion es la
siguiente creo que tengo problemas cuando trato de conectarme con la
base de datos… :S

este es parte de worker

class ReporteWorker < BackgrounDRb::MetaWorker
set_worker_name :reporte_worker

def generador_reportes

logger.info ’ > Generador de reportes Sao en ejecución <–> ’ +
Time.now.to_s

@numero_registros_prioridad_max = 10
@numero_registros_prioridad_med = 5
@numero_registros_prioridad_min = 3

///////////////////////////////////////////////////////////

/////////////DEFINICION DE LAS COLAS DE PRIORIDAD//////////

///////////////////////////////////////////////////////////

@cola_maxima_prioridad = OpseReporteConfiguracions.new (esta es la
linea 16)
@cola_mediana_prioridad = OpseReporteConfiguracions.new
@cola_minima_prioridad = OpseReporteConfiguracions.new
@cola_maxima_prioridad2 = OpseReporte.new
@cola_mediana_prioridad2 = OpseReporte.new
@cola_minima_prioridad2 = OpseReporte.new

///////////////////////////////////////////////////////////

//////////DEFINICION DEL CRITERIO DE PRIORIDAD/////////////

///////////////////////////////////////////////////////////

@Maxima = 1
@Media = 2
@Minima = 3

este es el error

Generador de reportes Sao en ejecución <–> Tue Mar 03 16:24:36 +0000
2009
uninitialized constant ReporteWorker::OpseReporte
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:477:in
const_missing' /usr/lib/ruby/tarea/lib/workers/reporte_worker.rb:16:ingenerador_reportes’
/usr/lib/ruby/tarea/vendor/plugins/backgroundrb/server/lib/meta_worker.rb:305:in
send' /usr/lib/ruby/tarea/vendor/plugins/backgroundrb/server/lib/meta_worker.rb:305:incheck_for_timer_events’
/usr/lib/ruby/tarea/vendor/plugins/backgroundrb/server/lib/meta_worker.rb:300:in
each' /usr/lib/ruby/tarea/vendor/plugins/backgroundrb/server/lib/meta_worker.rb:300:incheck_for_timer_events’
/usr/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/…/lib/packet/packet_core.rb:140:in
start_reactor' /usr/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/../lib/packet/packet_core.rb:139:inloop’
/usr/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/…/lib/packet/packet_core.rb:139:in
start_reactor' /usr/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/../lib/packet/packet_worker.rb:20:instart_worker’
/usr/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/packet_worker_runner:33:in
load_worker' /usr/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/packet_worker_runner:26:ininitialize’
/usr/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/packet_worker_runner:47:in
new' /usr/lib/ruby/gems/1.8/gems/packet-0.1.14/bin/packet_worker_runner:47 /usr/bin/packet_worker_runner:19:inload’
/usr/bin/packet_worker_runner:19

Perdón, pero no debería llamarse OpseReporteConfiguraciones ? parece que
le
faltara la última letra “e”

2009/3/3 Carlos C. [email protected]

Gracias pana era un error en los nombres de algunos modelos (Corneto82)

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs