Autotest with Growl not working

Hi I’m new and using Ruby on Rails 3 but when I run $ autotest nothing
happens (I have growl installed). If I run $ rspec spec then I get the
‘Finished in 0.07253 seconds seconds 2 example, 0 failures’ message

I have the following gems installed for autotest (checked via $ gem
list):

autotest (4.3.2)
autotest-fsevent (0.2.4, 0.2.2)
autotest-growl (0.2.9, 0.2.4)
autotest-rails-pure (4.1.0)

However none of them appear when I use $ bundle show. I read that that
was because they are not in my Gemfile for my project, although I do
have the following in my .autotest file in my home directory:

require ‘autotest/growl’
require ‘autotest/fsevent’

So I added the lines under my ‘group :test do’ in my Gemfile

gem ‘autotest-fsevent’ ‘0.2.4’
gem ‘autotest-growl’ ‘0.2.9’

and ran $ bundle check and get the following error:

Your Gemfile’s dependencies could not be satisfied
Install missing gems with bundle install

which I then try using $ bundle install

Fetching source index for http://rubygems.org/
Could not find gem ‘autotest-growl0.2.9 (>= 0, runtime)’ in any of the
gem sources.

And now I am totally stuck. Any help much appreciated!!

On 21 February 2011 23:38, Murph2m [email protected] wrote:

autotest-rails-pure (4.1.0)

gem ‘autotest-fsevent’ ‘0.2.4’
gem ‘autotest-growl’ ‘0.2.9’

That should be
gem ‘autotest-fsevent’, ‘0.2.4’
gem ‘autotest-growl’, ‘0.2.9’
with commas.

You can see this if you look at your gemfile it will have something like
gem ‘rails’, ‘3.0.4’
near the top.

Colin

Thanks Colin! sorry for the stupid error!

I am now getting something new:

h-3.2$ bundle exec autotest
/Users/mattmurphy/.rvm/gems/[email protected]/gems/
bundler-1.0.0/lib/bundler/shared_helpers.rb:100:in block in cripple_rubygems': autotest is not part of the bundle. Add it to Gemfile. (Gem::LoadError) from /Users/mattmurphy/.rvm/gems/[email protected]/bin/ autotest:18:in

From trying to read around maybe something to do with the $LOAD_PATH
(what is that) or maybe the Gemfile.lock?

Thanks in advance!

Ok I’ve added 'gem ‘autotest’, ‘4.3.2’ & gem ‘autotest-rails-pure’,
‘4.1.0’ to the Gemfile for this project and I no longer get the error
and I get the following message:

-bash-3.2$ bundle exec autotest
loading autotest/rails_rspec2
style: RailsRspec2


But nothing happens. Also in my first project I don’t remember needing
to add any of the autotest gems to the Gemfile for my local project.
Are they not setup via some sort of global gemfile?

Sorry a bit out of my depth here - I’m finding it quite tricky as a
newbie!

As further investigation I have looked into the shared_helper.rb file
in the path of the error and found the code that appears to be testing
for it:

spec = specs.find { |s| s.name == dep.name }

if spec.nil?
e = Gem::LoadError.new “#{dep.name} is not part of the
bundle. Add it to Gemfile.”
e.name = dep.name
e.version_requirement = dep.requirement
raise e

Tried googling ‘specs.find’ but no luck yet

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs