Autotest and RSpect

I managed to have Autotest running on my windows box. Apparently all is
working but every time I know there is an error a new line is generated,
no error messages or anything is sent to the console.

I am using pastie now (thanks to David), please go to:
http://pastie.caboo.se/106155

Daniel

Daniel,

I ran into this as well - see my posts here:
http://chrisdpratt.com/2007/09/04/rails-rspec-autotest-redgreen-and-snarl-reasons-i-dont-like-windows/

There’s a bug in ZenTest:
http://rubyforge.org/tracker/index.php?func=detail&aid=14203&group_id=419&atid=1678

The fix is to remove the smartness in zentest that attempts to construct
a proper path to Ruby on Windows (I assume that’s why they put it in
there).

So in the autotest.rb file in the ZenTest 3.6.1 gem, make sure that the
definition of the “ruby” method looks like this:

determine and return the path of the ruby executable.

def ruby
ruby = File.join(Config::CONFIG[‘bindir’],
Config::CONFIG[‘ruby_install_name’])

return ruby

end

and then autotest will be able to find your ruby executable.

Note that I never got the red/green thing working in snarl although it
does work in the command window if I do it there by hand.

Wes

Wes, I removed the spec.opts file and now I see the results of my specs,
but in plain text, no coloring. Well, at least I know it’s running.

I also tried playing with .autotest, adding/removing require’s to no
avail.

If you ever get the nice formatting working please let me know.

Thanks,

Daniel
Rails 1.2.3
ZenTest 3.6.1
RSpec 1.0.8 as a plugin

Oh one more thing, you need to remove the --colour option completely
from your spec.opts. The other stuff can stay - don’t know why, but it
matters…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs