Auto launch lighttpd in RC4


#1

Hi -

I run rails on OS X Tiger. I downloaded and built/installed from
source the lighttpd server.
It’s stored in /usr/local/sbin which is in my .bash_profile PATH

Office:~ mengelhart$ which lighttpd
/usr/local/sbin/lighttpd

I’ve updated to the Rails RC4 release as per the instructions and
everything is fine except that Webrick is the app server that gets
launched.

Any idea why script/server won’t launch lighttpd? Also the
documentation says that a lighttpd.conf is installed into config but I
don’t see it there. I’ve tried even creating a whole new project and
it will only lauch Webrick.

Thanks
Mike


#2

I did this very thing today, and it worked. Two things come to mind:

  1. Do you have the prce libs installed? You have to do this before
    configuring and installing lighty.
  2. Did you try ruby script/server lighttpd to see if you can force
    lighty to run?

Here is a post, while a little out of date, that helped me:
http://theexciter.com/articles/installing-lighttpd-on-osx


#3

Actually I didn’t have prce libs or fcgi installed! I followed the
instructions on that link and it works perfectly. Thank you.
Mike


#4

Probably a really dumb question but I do this all the time so…
After you added your path to .bash_profile, did you remember to login
again?

:slight_smile:

Sean

On Nov 19, 2005, at 7:30 AM, Brad D. wrote:

moosebrookfarm wrote:

I’ve updated to the Rails RC4 release as per the instructions and
Mike


Posted via http://www.ruby-forum.com/.


Rails mailing list
removed_email_address@domain.invalid
http://lists.rubyonrails.org/mailman/listinfo/rails

:::: DataFly.Net ::::
Complete Web Services
http://www.datafly.net