Auto_complete plugin for rails 2.2.2


#1

Can anyone help me as to why I can’t get this thing to work for rails
2.2.2? I get the following error when I ruby script/server:

=> Booting WEBrick…
C:/Ruby/lib/ruby/1.8/yaml.rb:133:in load': syntax error on line 5, col 11:-a=
-z (ArgumentError)
¤’
from C:/Ruby/lib/ruby/1.8/yaml.rb:133:in load' from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/ initializer.rb:819:i ndatabase_configuration’
from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/
initializer.rb:391:i
n initialize_database' from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/ initializer.rb:139:i nprocess’
from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/
initializer.rb:112:i
n send' from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/ initializer.rb:112:i nrun’
from C:/Users/marvin/Desktop/test_complete/config/
environment.rb:13
from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in ge m_original_require' ... 10 levels... from C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/commands/ server.rb:4 9 from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 31:inge
m_original_require’
from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
31:in `re
quire’
from script/server:3