Auth Problems with phpMyAdmin / Apache Proxy

Hi (just realised the other board does not post to the mailing list)

Setting up a Centos 5.5 VPS to run Nginx as a caching reverse proxy to
Apache and it is all peaches and cream apart from an issue with
authenticating into phpMyAdmin.

I have set up basic auth in Apache for requests to mysite/phpmyadmin as
I don’t want people bypassing auth by going directly to http:/
/mysite:apacheport/phpmyadmin

/phpMyAdmin is setup as an alias to the actual phpMyAdmin install
directory ln Apache.

Now, requesting http:/ /mysite:apacheport/phpmyadmin works fine. However
http:/ /mysite/phpmyadmin (i.e. via nginx), brings up the http auth
dialog fine but always returns an “incorrect password” response.

Any clues on how to get it working? I don’t want to add a redirect to
http:/ /mysite:apacheport/phpmyadmin under a /phpMyAdmin location in my
Nginx conf if possible.

I am on Nginx 0.7.65

Thanks

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,115727,115727#msg-115727

Finally got it working.

Changed my setup such that Apache only listened on internal IP 127.0.0.1
and moved the auth process to Nginx.

I think (but didn’t verify) the behaviour I saw may have been because my
htpasswd file had been created using only the -c flag and not -c -d.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,115727,115870#msg-115870

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs