Audio Sink Producing UaUaUaUa


When I have an audio sink in my flowgraph, leaving the device field
to default to speakers, I see a continuous stream of UaUaUaUa printed to
the console. What is this telling me? Disabling the audio sink stops the


Hi Richard,

these are audio Underruns, meaning that you did not supply the sound
system with the samples it needs for continuous playback in time.
following an old FAQ entry [1]:
If you have RF hardware in your flow graph, you might be seeing the
“two-clock problem”: No two oscillators are exactly the same, so if your
sample-producing hardware is a bit slower than it should be, or your
sound card is a bit faster, than you’ll see this.

Also possible is that you’ve used a sampling rate that your audio system
doesn’t actually support, and it automatically used a different one, so
that you end up with the same problem as above, even when things
should work (if the audio device actually consumed samples at the rate
you specified). Try 44100 or 48000 Hz, these work on most sound cards.

Another reason is that your system is simply too slow at calculating
samples, but that’s unlikely on modern hardware, unless you do something
very CPU-intense (e.g. a 400 tap filter, or something).

And yet another warning: Never ever use throttle in a flow graph with
hardware. It gives you the two-clock problem (one clock being sleep() of
your OS), AND it just “stops” samples in large chunks until enough time
has passed that a large-scale average sample processing rate is met. On
smaller scale, though, this leads to frequent underruns.




Every sample rate I try produces the UaUaUa pattern. I tried all the
in rates as well as 192 kHz.

When I run the gr-aduio dial-tone example, I get garbled noise as
instead of a dial tone, with the noise source turned off. Do you have an
idea what this might point to?

Pandora produces perfectly normal music coming out of my speakers as a
sanity check.


On Wed, Mar 25, 2015 at 10:59 AM, Marcus Müller
[email protected]