Audio Issues

I was able to get gnuradio to successfully compile using the script
available
at (http://gnuradio.org/redmine/projects/gnuradio/wiki/InstallingGR) and
I
updated my PYTHONPATH as the script instructed. However, none of the
audio
examples are working. They run without returning any errors, but I don’t
hear anything. As far as I can tell, I have ALSA installed (I’m using
Ubuntu
10.04 with kernel 2.6.32-38, all updates installed). I tried updating
gr-audio.conf to use alsa and tried changing gr-audio-alsa.conf to use
plughw:0,0 instead of hw:0,0 - all to no avail. I don’t believe oss is
installed on this system. Can anyone suggest a solutions? Thanks ahead
of
time!

Edit: Sorry if this message is a repost, I’m having some trouble getting
registered through Nabble.

View this message in context:
http://old.nabble.com/Audio-Issues-tp33402959p33402959.html
Sent from the GnuRadio mailing list archive at Nabble.com.

Have you tried playing audio from a different source? If you go to
youtube.com, and watch a video, can you hear the sound?

Cheers,
Ben

On Mon, Feb 27, 2012 at 8:21 PM, labarowski [email protected]
wrote:

plughw:0,0 instead of hw:0,0 - all to no avail. I don’t believe oss is
installed on this system. Can anyone suggest a solutions? Thanks ahead of
time!

Try passing the device string “-O pulse” to use pulseaudio, instead. You
might have to install libpulse0, though. I’ve found this to be a more
flexible and reliable sound system.

Tom

On 27/02/12 08:59 PM, Tom R. wrote:

Try passing the device string “-O pulse” to use pulseaudio, instead.
You might have to install libpulse0, though. I’ve found this to be a
more flexible and reliable sound system.

Tom

I’ve never found any sound subsystem on Linux to be “reliable and
flexible”. And when you have a system
with both Pulse and Alsa-backwards-compat-mode, it’s a frikken
nightmare. The problem seems to be that
for over a decade, everybody wanted their Kewl sound subsystem to be
incorporated into Linux distributions.
So everyone go their wish, and there are no standards.

Bleh.


Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

On Mon, Feb 27, 2012 at 9:03 PM, Marcus D. Leech [email protected]
wrote:

with both Pulse and Alsa-backwards-compat-mode, it’s a frikken
nightmare. The problem seems to be that
for over a decade, everybody wanted their Kewl sound subsystem to be
incorporated into Linux distributions.
So everyone go their wish, and there are no standards.

Bleh.

All I’m saying is that pulseaudio on Ubuntu seems to just work these
days.

Tom

Thanks for the replies everyone! Tom, I’m not entirely sure how to “pass
“-O
pulse””, but I did change gr-audio.conf to use pulse and that seems to
have
done the trick. Thanks! +1 for pulse!

labarowski wrote:

is installed on this system. Can anyone suggest a solutions? Thanks ahead
of time!

Edit: Sorry if this message is a repost, I’m having some trouble getting
registered through Nabble.


View this message in context:
http://old.nabble.com/Audio-Issues-tp33402959p33404169.html
Sent from the GnuRadio mailing list archive at Nabble.com.

On 27/02/12 09:10 PM, Tom R. wrote:

All I’m saying is that pulseaudio on Ubuntu seems to just work these
days.

Tom
Well, I should perhaps re-visit Pulse sometime in the coming year or
so. I currently just use Alsa nomenclature,
and that seems to work.


Principal Investigator
Shirleys Bay Radio Astronomy Consortium
http://www.sbrac.org

On Mon, Feb 27, 2012 at 9:24 PM, labarowski [email protected]
wrote:

Thanks for the replies everyone! Tom, I’m not entirely sure how to “pass
“-O
pulse””, but I did change gr-audio.conf to use pulse and that seems to have
done the trick. Thanks! +1 for pulse!

Most audio examples have a command-line option to specify the audio
device.
For output scripts, this is -O, when coming from a mic input, it’s -I.
Instead of specifying it in the config file, you could just put these on
the command line. But it’s probably better to have it permanently put
into
the config file so you don’t have to keep typing it in all the time.

Tom

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs