Attachment_fu stopped uploading files to S3

Hey everyone,

I’ve been using attachment_fu to upload large media files to S3 with
great success in my rails application. However, it has recently
stopped uploading.

My app appears to be uploading to somewhere, as my browser is
displaying a 'sending request to…" status message for about the
right length of time. The records are also created in my application
database. However, the files are never created in my S3 bucket.

I have enabled logging for my bucket, and have not seen any PUT
requests for the appropriate files. I can successfully upload file
manually using the ruby front-end s3sh. So this appears to be an
issue related to attachment_fu.

I run my app on Lighttpd and FCGI. I have recently killed and
restarted my FCGI dispatch process, and noticed the problem started
around that time. Might attachment_fu be sensitive to that somehow?
Or not at all?

Any insights would be appreciated! Thanks very much.

I’ve solved this problem.

I’m not sure what caused the need for the change, but I had to adjust
some custom hostname configuration logic I had implemented earlier in
attachement_fu’s s3_backend.rb.