Attachment_fu not working on Textdrive

I have attachment_fu working on my local Windows machine (localhost:

But when I transfer it to Textdrive (Solaris), it doesn’t work. Any

Give it a shot:

I haven’t got the logger working yet on TextDrive, but that will be my
next step. Any suggestion on what things to look at first?


It seemed to upload fine for me,

how if the problem is in the listing, consider the file location/or
permissions on the directory of where the files are being uploaded to.

I changed the file permissions to 777 all the way down to the storage
directory (/public/raw_data_files) for the sake of testing and it
still does not work.

It did work once when I first uploaded it but hasn’t worked since.

any more ideas? thanks


What about the setting of attachment_fu, does it use a different image
processing or storage facility on the production server?

I’m also having problems getting attachment_fu to work on my shared
TextDrive host.

I’ve tried using all three of the image processing packages but get
the same error (below) with each.

chirag, have you had any success getting this working?

The error I get is the following:

NoMethodError: undefined method alias_method_chain' for Image:Class from /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/ active_record/base.rb:1129:inmethod_missing’
from script/…/config/…/config/…/vendor/plugins/
mini_magick_processor.rb:8:in included' from script/../config/../config/../vendor/plugins/ attachment_fu/lib/technoweenie/attachment_fu.rb:92:ininclude’
from script/…/config/…/config/…/vendor/plugins/
attachment_fu/lib/technoweenie/attachment_fu.rb:92:in has_attachment' from script/../config/../config/../app/models/image.rb:10 from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/ active_support/dependencies.rb:140:inload’
from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/
active_support/dependencies.rb:140:in load' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/ active_support/dependencies.rb:56:inrequire_or_load’
from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/
active_support/dependencies.rb:30:in depend_on' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/ active_support/dependencies.rb:85:inrequire_dependency’
from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/
active_support/dependencies.rb:98:in const_missing' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/ active_support/dependencies.rb:131:inconst_missing’
from (irb):1

Which, while I’m pretty much a Rails newbie, leads me to believe that
possible the version of rails running on the host (Rails 1.1.6) is not
up-to-date enough to support attachment_fu… Is that a fair


attachment_fu requires Rails 1.2+.

On 7/15/07, chirag [email protected] wrote:

def default_url_options(options)
{ :trailing_slash => true }

You do realize that’s due to funky rewrite rules in apache, right?
I’ve never run into that with nginx. I think you can just put this in
your htaccess too:

DirectorySlash Off

Rick O.

Actually, the server is using lighttpd. The same thing may be occuring

I found the answer to my own problem

After some debugging and logging, I noticed that the ‘create’ action
was not being registered by Rails. The ‘new’ action would jump
straight to the ‘index’ action, which is a display list of the
uploaded files. Thanks to Steve E.’ June 20, 2007 blog entry, I
found a workaround. Add this to the body of the ApplicationController
class in application.rb :

def default_url_options(options)
{ :trailing_slash => true }