Arrancar servidor


#1

Buenos dias, tengo un pequeño problema tengo una aplicacion en rail
pero el jefe decidio cambiar de la version de rails con la que se esta
desarrollando anteriormente usabamos 2.1.0 y ahora hay q usar la 2.1.2
me arroja este error.

Cuando quiero arrancar el servidor a mi jefe y otros compañeros de
trabajo les funciona la aplicacion perfectamente pero a mi no si me
pueden ayudar como se los agradeceria saludos.

“6036”
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.1.2 application starting on http://127.0.0.1:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 127.0.0.1:3000
** Starting Rails with production environment…
Exiting
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/commands/servers/mongrel.rb:16:
warning: already initialized constant OPTIONS
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/commands/servers/mongrel.rb:19:
undefined method options' for []:Array (NoMethodError) from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:ingem_original_require’
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
require' from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:510:inrequire’
from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:355:in
new_constants_in' from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:510:inrequire’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/commands/server.rb:39
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from ./script/server:3
from -e:2:in `load’
from -e:2


#2

warning: already initialized constant OPTIONS
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/commands/servers/mongrel.rb:19:
undefined method `options’ for []:Array (NoMethodError)

A veces he visto este error cuando hay problemas con alguna gema.
También a veces he visto que si arrancas la aplicación con mongrel_rails
start en lugar de con script/console da algún mensaje más amigable.

suerte,


javier ramírez

…i do ruby on rails development in madrid, spain, at
http://www.aspgems.com
…you can find out more about me on http://formatinternet.wordpress.com
and http://workingwithrails.com/person/5987-javier-ramirez


#3

Robert B. wrote:

Buenos dias, tengo un pequeño problema tengo una aplicacion en rail
pero el jefe decidio cambiar de la version de rails con la que se esta
desarrollando anteriormente usabamos 2.1.0 y ahora hay q usar la 2.1.2
me arroja este error.

Cuando quiero arrancar el servidor a mi jefe y otros compañeros de
trabajo les funciona la aplicacion perfectamente pero a mi no si me
pueden ayudar como se los agradeceria saludos.

C:\Documents and Settings\Bellorin Robert\Mis
documentos\Aptana\kns2>ruby script/server
=> Booting Mongrel (use ‘script/server webrick’ to force WEBrick)
=> Rails 2.1.2 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
Exiting
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/commands/servers/mongrel.rb:16:
warning: already initialized constant OPTIONS
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/commands/servers/mongrel.rb:19:
undefined method options' for []:Array (NoMethodError) from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:ingem_original_require’
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
require' from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:510:inrequire’
from
c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:355:in
new_constants_in' from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:510:inrequire’
from
c:/ruby/lib/ruby/gems/1.8/gems/rails-2.1.2/lib/commands/server.rb:39
from
c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from script/server:3

C:\Documents and Settings\Bellorin Robert\Mis documentos\Aptana\kns2>

verga no es mucha la diferencia


#4

verga no es mucha la diferencia

en realidad tranquiliza ver que si ejecutas dos veces exactamente el
mismo comando obtienes la misma respuesta. Te decía que en lugar de
hacer script/server (no lo hagas)… hagas “mongrel_rails start”

a veces la traza es más amigable

saludos,


javier ramírez

…i do ruby on rails development in madrid, spain, at
http://www.aspgems.com
…you can find out more about me on http://formatinternet.wordpress.com
and http://workingwithrails.com/person/5987-javier-ramirez


#5

a veces la traza es más amigable

y si no lo es, la otra pista es la de mirar las gemas… puede que
necesites alguna gema que no esté en tu máquina. Compara con un gem list
tu listado con el de algún compañero al que sí le funcione, a poder ser
que también use windows. A veces la misma gema en windows/linux no se
comporta exactamente igual


javier ramírez

…i do ruby on rails development in madrid, spain, at
http://www.aspgems.com
…you can find out more about me on http://formatinternet.wordpress.com
and http://workingwithrails.com/person/5987-javier-ramirez


#6

Robert B. wrote:

Desistale el ruby y lo reinstale el problema sigue q triste es mi vida

vos como que soy de maracaibo


#7

Desistale el ruby y lo reinstale el problema sigue q triste es mi vida


#8

2009/3/17 Robert B. removed_email_address@domain.invalid:

Desistale el ruby y lo reinstale el problema sigue q triste es mi vida

A todos nos ha pasado.

Que plugins tienes instalados? Que dependencias tiene tu aplicación.
Cuando pasan estas cosas, en mi opinión, lo mejor que se puede hacer
es … respirar hondo y empezar a resolver las cosas poco a poco.

Solución que yo recomiendo, porque así entiendes que està fallando …

  1. Funciona Rails? Crea un nuevo proyecto en tu maquina con la misma
    versión de Rails.

    $ rails 2.1.2 demo_rails

  2. Arranca el servidor, y comprueba que Rails no es lo que falla.

  3. Que gemas y/o plugins depende tu proyecto? Incluyelas en tu nueva
    demo y comprueba que no sea eso.

Solución rápida … preguntarle a Google y sálvese quien pueda …

"undefined method `options' for []:Array (NoMethodError)"

#9

Muchas gracias por participar les digo que hice

Uno borre la aplicacion y el problema seguia cuando hacia el checkout,
entonces cree una nueva aplicacion en rails y arranque el servidor sin
problemas.

volvi hacer checkout y cambio el error, donde me decia que faltaban una
gemas las instale y fino.

Asi quien me dice a la final cual es la moraleja, y al amigo venezolano
soy de Valencia - venezuela salu2 y gracias a todos por sus tiempo y
colaboracion


#10

Si actualizas un proyecto no olvides darle:
rake rails:update

para que también actualizen los archivos de script y demas,

Benjamín

Robert B. escribió: