ArgumentError when installing plugins with -x


#1

This is the second time that I’ve tried to install plugins where this
error has occured. It only occurs when I use the -x flag.

script/plugin install -x
svn://cartographer.rubyforge.org/trunk/vendor/plugins/cartographer
/usr/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:675:in
method': wrong number of arguments (0 for 1) (ArgumentError) from /usr/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:675:indetermine_install_method’
from
/usr/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:690:in
parse!' from /usr/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:411:inparse!’
from
/usr/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:427:in
parse!' from /usr/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/commands/plugin.rb:823 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:inrequire__’
from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
require' from /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:inrequire’
from script/plugin:3

What is the problem?