Arch linux , swf dir and forbidden error

I use arch linux and install nginx from arch repo , every thing is OK, I
want use nginx for use play flash game and swf game , i download many
swf
files and make swf directory in
/usr/share/nginx/html
and put all swf files in swf directory and after that I set 755 for swf
directory and set 644 for all swf files , but when I type in browser
like
firefox type
http://127.0.0.1/swf
I see this error
403 Forbidden
and I can not play sw game
but when I type
http://127.0.0.1/swf/pacman.swf
every thing is good and I can flash game
what is problem ?
I set 777 ,for folder and all swf but I see that problem again and I see
403 Forbidden

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,250709,250709#msg-250709

On Fri, Jun 06, 2014 at 11:57:22AM -0400, mfaridi wrote:

Hi there,

http://127.0.0.1/swf
I see this error
403 Forbidden
and I can not play sw game
but when I type
http://127.0.0.1/swf/pacman.swf
every thing is good and I can flash game
what is problem ?

What does error_log say?

Most likely there is no index.html file, or autoindex
(http://nginx.org/r/autoindex) is not on, is my guess.

f

Francis D. [email protected]

Francis D. Wrote:

every thing is good and I can flash game


nginx mailing list
[email protected]
http://mailman.nginx.org/mailman/listinfo/nginx

when I type
tail -f access.log

I see these

127.0.0.1 - - [08/Jun/2014:02:39:03 +0430] “GET /swf/ HTTP/1.1” 403 168
“-”
“Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0”
127.0.0.1 - - [08/Jun/2014:02:39:04 +0430] “GET /favicon.ico HTTP/1.1”
404
168 “-” “Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101
Firefox/29.0”
127.0.0.1 - - [08/Jun/2014:02:40:00 +0430] “GET /swf/ HTTP/1.1” 403 168
“-”
“Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0”
127.0.0.1 - - [08/Jun/2014:02:40:27 +0430] “GET /swf/ HTTP/1.1” 403 168
“-”
“Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0”
127.0.0.1 - - [08/Jun/2014:02:41:24 +0430] “GET /swf/ HTTP/1.1” 403 168
“-”
“Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0”

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,250709,250726#msg-250726

On Sat, Jun 07, 2014 at 05:05:46PM -0400, mfaridi wrote:

Francis D. Wrote:

On Fri, Jun 06, 2014 at 11:57:22AM -0400, mfaridi wrote:

Hi there,

What does error_log say?

Most likely there is no index.html file, or autoindex
(http://nginx.org/r/autoindex) is not on, is my guess.

127.0.0.1 - - [08/Jun/2014:02:39:03 +0430] “GET /swf/ HTTP/1.1” 403 168 “-”
“Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0”

So the request you make is “/swf/”.

The response you get is http 403.

What response do you want to get?

error_log might say why you get the 403 response.

f

Francis D. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs