AR_Mailer Problem


#1

Hi all,

I am using ar_mailer for sending newsletter. I got mails queued in
emails table. However when running ar_sendmail to begin sending the
mails, an exception is thrown:

Unhandled exception wrong number of arguments (7 for 6)
(ArgumentError):
/usr/lib/ruby/gems/1.8/gems/ar_mailer-1.3.1/lib/action_mailer/
ar_sendmail.rb:408:in start' /usr/lib/ruby/gems/1.8/gems/ar_mailer-1.3.1/lib/action_mailer/ ar_sendmail.rb:408:indeliver’
/usr/lib/ruby/gems/1.8/gems/ar_mailer-1.3.1/lib/action_mailer/
ar_sendmail.rb:500:in run' /usr/lib/ruby/gems/1.8/gems/ar_mailer-1.3.1/lib/action_mailer/ ar_sendmail.rb:496:inloop’
/usr/lib/ruby/gems/1.8/gems/ar_mailer-1.3.1/lib/action_mailer/
ar_sendmail.rb:496:in run' /usr/lib/ruby/gems/1.8/gems/ar_mailer-1.3.1/lib/action_mailer/ ar_sendmail.rb:340:inrun’
/usr/lib/ruby/gems/1.8/gems/ar_mailer-1.3.1/bin/ar_sendmail:5
/usr/bin/ar_sendmail:19:in `load’
/usr/bin/ar_sendmail:19

I am using ar_mailer version 1.3.1.

I know the solution is this below:

The solution is: make them match either by providing the all required
arguments or delete those unavailable arguments (for you) in the
ar_sendmail function.

How exactly do I fix this error. I am new to RoR. Can someone give
me the steps to modify the environment file please.

Thank you,

Sean McGilvray


#2

which ruby version are you using? I think I had a similar problem
using ruby 1.8.7 and solving it by downgrading to 1.8.6…

On Fri, Feb 13, 2009 at 5:23 PM, Sean McGilvray removed_email_address@domain.invalid
wrote:

ar_sendmail.rb:408:in `start’
/usr/lib/ruby/gems/1.8/gems/ar_mailer-1.3.1/bin/ar_sendmail:5

How exactly do I fix this error. I am new to RoR. Can someone give
me the steps to modify the environment file please.

Thank you,

Sean McGilvray


/**