Ar-extensions-0.8.0 - "ActiveRecord::Extensions::FindToCSV"


#1

Hi All,

Facing some problem with the new version of the ar-extensions-0.8.0.
With the previous version of this ar-extensions-0.7.0, I was able to use
the
“include ActiveRecord::Extensions::FindToCSV” without any problems.

When I had upgraded the version of ar-extensions to 0.8.0, I started
getting this error

/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:263:in
`load_missing_constant’: uninitialized constant
ActiveRecord::Extensions::FindToCSV (NameError)

So, is there any other kind of library I need to add or something?

I am using

ruby
ruby 1.8.6 (2007-03-13 patchlevel 0) [sparc-solaris2.10]

rails
rails (1.2.5, 0.13.1)

ar-extensions
ar-extensions (0.8.0, 0.7.0)

actionmailer (2.0.2, 1.3.6, 1.3.5, 1.0.1)
actionpack (2.0.2, 1.13.6, 1.13.5, 1.9.1)
actionwebservice (1.2.6, 1.2.5, 0.8.1)
activerecord (1.15.6, 1.15.5, 1.11.1)
activeresource (2.0.2)
activesupport (2.0.2, 1.4.4, 1.1.1)
acts_as_paranoid (0.3.1)
acts_as_versioned (0.2.3)

Thanks in advance,
Regards,
Anand


#2

Hey,
Seems I found out the solution.

Ha Ha…

ar-extensions-0.8.0 is not compatible with any rails version below
2.0.2.

can refer to this site
http://www.continuousthinking.com/tags/arext

Regards,
Anand.

Anand S. wrote:

Hi All,

Facing some problem with the new version of the ar-extensions-0.8.0.
With the previous version of this ar-extensions-0.7.0, I was able to use
the
“include ActiveRecord::Extensions::FindToCSV” without any problems.

When I had upgraded the version of ar-extensions to 0.8.0, I started
getting this error

/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:263:in
`load_missing_constant’: uninitialized constant
ActiveRecord::Extensions::FindToCSV (NameError)

So, is there any other kind of library I need to add or something?

I am using

ruby
ruby 1.8.6 (2007-03-13 patchlevel 0) [sparc-solaris2.10]

rails
rails (1.2.5, 0.13.1)

ar-extensions
ar-extensions (0.8.0, 0.7.0)

actionmailer (2.0.2, 1.3.6, 1.3.5, 1.0.1)
actionpack (2.0.2, 1.13.6, 1.13.5, 1.9.1)
actionwebservice (1.2.6, 1.2.5, 0.8.1)
activerecord (1.15.6, 1.15.5, 1.11.1)
activeresource (2.0.2)
activesupport (2.0.2, 1.4.4, 1.1.1)
acts_as_paranoid (0.3.1)
acts_as_versioned (0.2.3)

Thanks in advance,
Regards,
Anand